Page not loading for Preview

Just upgraded to the most current release and none of my pages can be viewed in page preview.
I get this message on every page preview.

Error messages in the browser console? 

None.  in fact I was on a skype call with Pat Vachon when we tried to do a preview of a page and then he noticed on my sight, Dorothy.com that an iframe page to skuid showed the same screen.  He looked for errors and found none.

This happens on every screen I have tried on Skuid.

Same here…  “Loading” message on all Skuid pages.

Here’s the error that I see in the Console: 

Failed to load resource: the server responded with a status of 404 (Not Found)

I’m not sure how much of this is relevant, but here’s what I see when I try to reload the page:

It looks like we’ve got a bug. The issue occurs when you have a theme that does not have any Web Fonts. I think “Classic” is the only these we deliver without Web Fonts, and thus themes based on Classic would have the same issue. In any case, I’ve logged it, and we’ll get it patched up as soon as we can. In the mean time, a workaround would be to add a Custom font to your theme. A good option is Salesforce Sans, which we deliver with Skuid:

Name - SalesForce Sans
URL - /resource/skuid__Fonts/sfsans/sfsans.css

THANK YOU!  Adding a font fixes this issue indeed.  Disaster averted.  

I use a complete custom theme if that helps

I guess Elissa has hers fixed. My site is still down. I gave you sign on

Bill,

All themes created with the Skuid Theme composer have a “base theme” which is selected when you first create them. Go to the Themes List and click the “Create New Theme” button:

Classic is the default, so unless you changed it when you created the theme, Classic is your theme’s base theme. Classic does not have any Web Fonts associated with it, so unless you opened your theme for editing, clicked on Web Fonts, and added at least one Google Font, Custom Font or a Typekit id, then saved your theme…

…you’ll get the behavior you are describing. I’m recommending that you add SalesForce Sans as a workaround since we deliver it with our Skuid package (see previous response for Name/URL values). This is what worked for Elissa. We also have a tutorial on adding Web Fonts but it uses Google Fonts as an example.

Does that get you up and running again?

It shows but there is still an error. Look at page R_Detail_Member_DNA and preview with the
name “Robert Page”

It is still not working

Bill,

I think you’ve entered the wrong value for the URL of your custom font. It looks like you’ve only got one underscore between “skuid” and “Fonts” and there should be “/sfsans/sfsans.css” after that. The full URL is…

/resource/skuid__Fonts/sfsans/sfsans.css

Did you get this fixed last night Bill?  We think J’s suggestion should have solved things.  Did it? 

Yes. It did. Thank you.

The root issue preventing the page from loading is now resolved as of Banzai - Update 7.4, available via Skuid Releases.