Page Include Working in 1 tab and not in another for same user...

Hi I’m having this issue with different pages and different profiles…

I use this page as Page include in a popup in 2 different places and using the same query string

For a specific profile, they can see one popup properly(screenshot #2) and the other is giving a Status 500 error (screenshot #1)

I looked in console’s network tab, both send out the exact same URL

Same issue with some other pages and some other profile…

I’m at a complete lost at this point…

If I try both (i have admin profile) and can see them both properly…

Any help would be appreciated


2)

Hey Dave,

Are there restricted field level security settings? Do both of your users/profiles have access to the same object/models?

What about visualforce page access?

Hi Karl,

Yes, they have access to VF page and fields needed.


And as explained,  the same profile/user  can access the page include on 1 tab without any prob and getting error on another

If it was a permission or VF issue, none of the page would work, not just 1 of them…

Seeing as it’s the same page include with same query string, they should both work or both not work. 


Looking @ other posts in forum seems i’m not the only one with this issue, found so far 2 other recent posts with kind of same issue…

Skuid may have a bug

http://community.skuid.com/skuid/topics/page-include-not-working-when-on-different-user-profile

http://community.skuid.com/skuid/topics/there-was-an-error-attempting-to-load-the-requested-page

Hopefully someone official can look into it, i’m willing to grant login access if needed

This bug is bugging me ! :smiley:

Thank you



HI it’s been 3 months but noone has been able to answer me…

This issue is till not fixed for me

And had a similar issue this morning on another page (home page skuid equivalent) and by adding that page in VF for that home page assignment, it worked.

Tried to do same on page mentioned on OP , but was not able to fix it.

Is there something i need to add to the VF page for those page includes to work?

This is the VF i use for to overide that Lead List View

<apex:page standardController=“Lead” recordsetvar=“a” extensions=“skuid.Redirects”
showHeader=“true” sidebar=“true” readonly=“true” docType=“html-5.0” action="{!IF(canUseSkuid,’’,redirect)}" title="{!$ObjectType.Lead.labelPlural}"> <skuid:page objectType=“Lead” actionType=“List” /> </apex:page>

Ans then have a page assignment set up But the Page includes on that Skuid page give error: There was an error attempting to load the requested page.

looking in console the error is the following when i try to open popup with those page includes:

Failed to load resource: the server responded with a status of 500 (Server Error)

help please

In case someone has same issue, Amy just gave me solution on another post, that I applied here and it works!
see: http://community.skuid.com/skuid/topics/unrecognized-content-security-policy-directive-referrer?top…