Page include on site

Hi working on my first Skuid site, and i’m having a little basic issue.

I followed instructions here, and until now all was fine.

Main page works great, now trying to have a popup with a page include , and it’s not working when on Says loading and nothing else…

-I tried creating a new VF redirect for that page and gave permission to it on the public profile of that site

-As well Site has permission to the objects /fields on that “page include”

In salesforce i can view it fine, so it’s a issue.

Was i suppose to include the page include redirect in Same vf as original page?
if yes, pls let me know how so.

I’m sure i’m missing something simple…

here’s the VF I used on original page

<apex:page standardController=“Account”
extensions=“skuid.Redirects” action="{!redirect}?page=Site_offers">


I once also tried to create a public accessible Skuid page and the tutorial you posted wasn’t enough for me to get it working.

One thing was that I didn’t use skuid:page

Maybe that is the same issue on your problem.

Instead of a redirect to the skuid page, add the tag

<skuid:page page="Site_offers" />

Inside the apex:page.…

Maybe this quick tutorial can help you aswell :slight_smile:

Thank you Thimo for your help.

My main page is accessible by the public and works perfectly.

My issue is that I have a popup button on that main page that uses a “page include” to show another skuid page.

This page is not working on the public site.

I looked at your detailed tutorial, and I have done the exact same steps, except did not use Skuid:page.

In your opinion would that make a difference in regards to my specific problem?

Here’s error I get on console when clicking on button with page include:


Dave.  You are using the skuid:page redirect method for the public site.  As you should. 

ONe of the considerations for using this mechanism is that you need to make local copies of  a set of VF pages that come with Skuid.  Look at this tutorial:… (look especially at the considerations section)

This should correct your issue. 

Nice Tutoral Thimo! 

Rob, you are 100% correct that was all I was missing.

At the same time you fixed my issue with uploading documents on public site!

Thank you very much to you and Thimo :slight_smile: