Page include not working when on different user profile

I have multiple page includes that work fine when I view the parent skuid page as myself, however when i try to view them as a different user profile, I get the following error: “There was an error attempting to load the requested page.” This is for every single page includes in the system.

I have tried changing the model conditions on the actual page include pages as well as changing the query string for the page include but nothing seems to work. 

The thing is they were working a few days ago and the only change I made was updating Skuid from 8.8 to 8.15. Could this be the reason that everything seems to have gone haywire?

Help Please!

Would anyone know why this is happening?


It sounds like it might have to do with permissions, but it’s odd that it just started. Have the permissions for the user profile changed recently? Can you give any more information about the error, or maybe a screenshot of it? Do you see any errors in the Chrome developer console for those pages? Does this error happen when you try to view the Skuid pages in page builder or when you try to preview them?


Just a guess,

have you tried checking the permissions on the “Include” Visualforce Page?

Perhaps the update has overridden that Page and now it misses the permission to those Profiles.

l’ll check these and come back to you. I’ve just reproduced the pages in xml straight into the main page for now as i’m going live today and had to find a workaround, but when im back in sandbox for the next piece ill check the permission sets. Thanks for the answers guys, really appreciate it.