Page Builder Not Working in Spark (API v2)

Hi - when trying to use the page builder to create a new page (API v2) I get this error: 

1. There was a problem rendering a component of type skuid__pageBuilder: Cannot read property ‘indexOf’ of undefined

Here’s a gif of the error happening:

Hi Kaede, bummed that you’re getting an error just trying to open the Page Composer :( 

Can you open the Chrome JavaScript Console and copy/paste any error messages that appear there? Thanks!

Do you have access to Skuid Page Builder?

Hi Zach! Sure thing: Failed to load resource: the server responded with a status of 404 (Not Found)
skuidReqs.js:1 JQMIGRATE: Migrate is installed, version 3.0.1
skuidReqs.js:1 There was a problem rendering a component of type skuid__pageBuilder: Cannot read property ‘indexOf’ of undefined
log @ skuidReqs.js:1
skuidReqs.js:1 TypeError: Cannot read property ‘indexOf’ of undefined
    at d (skuidReqs.js:1)
    at Object.createIcon (skuidReqs.js:1)
    at i (/resource/1544119245000/skuid__next/js/builderReqs.js:2)
    at $.eval (/resource/1544119245000/skuid__next/js/builderReqs.js:2)
    at Function.each (skuidReqs.js:1)
    at new o.ComponentsViewer.t.ComponentsViewer (/resource/1544119245000/skuid__next/js/builderReqs.js:2)
    at Object.render (/resource/1544119245000/skuid__next/js/builderReqs.js:2)
    at I.render (skuidReqs.js:1)
    at I.conditionallyRender (skuidReqs.js:1)
    at k (skuidReqs.js:1)

I can open the page builder for pages with API v1

Hmmmm… This is a bit of a guess, but try it in an Incognito Window. We have seen some bizarre caching issues post upgrade before, but if the behavior is the same in an IW, that will rule that out right away. 

I just tried in incognito and get the same behavior.

OK, I think I might have figured it out. I was able to reproduce the behavior and find a potential workaround, but beware: it’s a little round about, and I’m not sure what side effects it might have for you, so you’ll want to do some v1 testing if this works. Try this:

  1. Go to Salesforce Setup > Develop > Custom Settings
  2. Click Manage next to the Preference record (skuid namespace, in case you have another Preference Custom Setting)
  3. Click the Edit button at the top
  4. If Use Component Packs is unchecked, check it and click the Save button
  5. Try it again
If anything breaks for you, you can always uncheck that box and save again. We will look into fixing this behavior, but let us know if this gets you back in business or not!

Yay!!! It worked! Thank you so much!

For others experiencing this issue, the workaround is to check Use Component Packs as J describes above.

We will be fixing the issue in next Spark patch, 12.0.2.