No error on thrown by blank required field.

Primary Phone is a required field (in the ui, not in sfdc), but the model is saving just fine with the value blank. Interestingly, the field itself doesn’t seem to be in the model’s data.

Can you give us a little more context?  Is this an existing record being updated?  A new record? How does this form get populated?  Etc.  Can you reproduce the issue in a simple test page using standard objects?  Certainly an ugly error and we want to help…

It’s an existing record that’s being updated. This is the second step of a wizard.

I haven’t tried to reproduce, but my guess would be that if the record is existing in SFDC, the field is blank, it’s required in the ui but not SFDC, and the user doesn’t make any changes to the field, skuid doesn’t throw the error.

That should not be happening.  In my orgs - if a existing record field is blank but is required in the UI - when the existing record opens you can’t save it until filling the field in some way.  Somthing else is going on here. 

Ok. Do you mind taking a look if I give login access?

Yes.  We don’t mind taking a look if you grant us login rights.  Just send an email to support@skuidify.com with the org ID and the repro steps. 

IF you could set the login rights for at least a week - we’d be grateful.  With Dreamforce this week,  I don’t know how much we are going to get done… 

Well, this is somewhat embarrassing, but ultimately good…

I find myself unable to reproduce the problem! If we run across it again, I’ll let you know.

Hi Matt, Have you find a solution for this issue, I am also facing the same issue…