No arguments included in conditional render snippet for table global action - 9.5.4

As per title.

Kinda important. :wink:

Hi Pat,

I’ve looked for what’s missing, but need a little more information to find the spot you’re referring to, if you wouldn’t mind. 

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" useviewportmeta="true" showheader="true"> <models> <model id="Accounts" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" type="" sobject="Account"> <fields> <field id="Name"/> <field id="Id"/> </fields> <conditions/> <actions/> </model> </models> <components> <skootable showconditions="true" showsavecancel="true" showerrorsinline="true" searchmethod="server" searchbox="true" showexportbuttons="false" pagesize="10" createrecords="true" model="Accounts" buttonposition="" mode="read" allowcolumnreordering="true" uniqueid="sk-1Ozahe-120"> <fields> <field id="Name" hideable="true" uniqueid="fi-1O_5eY-218"/> </fields> <rowactions> <action type="edit"/> <action type="delete"/> </rowactions> <massactions usefirstitemasdefault="true"> <action type="massupdate"/> <action type="massdelete"/> </massactions> <views> <view type="standard"/> </views> <actions defaultlabel="Global Actions" defaulticon="sk-icon-magic" usefirstitemasdefault="true"> <action type="multi" label="This Has a Render Snippet" icon="sk-icon-add"> <actions/> <renderconditions logictype="and"> <rendercondition type="fieldvalue" operator="=" enclosevalueinquotes="true" fieldmodel="Accounts" sourcetype="snippet" nosourcerowbehavior="deactivate" sourcesnippet="renderSnippetHere"/> </renderconditions> </action> </actions> </skootable> </components> <resources> <labels/> <javascript> <jsitem location="inlinesnippet" name="renderSnippetHere" cachelocation="false">var params = arguments[0], $ = skuid.$; console.log(params);</jsitem> </javascript> <css/> </resources> <styles> <styleitem type="background" bgtype="none"/> </styles> </skuidpage> 

I have been able to reproduce this issue. Thank you for bringing it to our attention. We’ll update as soon as a fix is presented.

I noticed this was still not working in 10.0.4 for table row actions as well, any news on this as it seems to make working out what row you are on impossible

Yup. Forgot I had reported this back in April of last year. Rediscovered this little gem. Can you please rectify this ASAP.

The workaround is a real pain. Way more code and super hacky.

Pat, can you explain which arguments you would expect to see on a table’s global action render snippet?

Standard stuff. The model, component, context, list.

Pat - I wanted to close the loop on this, and let you know this has been surfaced to our product team. We don’t have any roadmap details, but it makes sense that you’d want to provide the snippet some contextual information about the conditionally rendered element in question. 

Another client. Same need. :confused:

yes please

Pat do mind sharing how you worked around it?

No idea which page for which this was for and whether or not I found a work around. :confused:

Ok. Thanks anyway. If inspiration hits lmk.