Navigation Component in Skuid V2 not picking up context?

I have a nav menu embedded in a deck and for some reason it is not inheriting the context id.

Have tried everything. I can replace it with a button set and it picks up the right Id no problem but we really want to use the Nav menu goodness!

The use case is to update a field on the relevant record only but it consistently updates the field on every row.

Any tips? Have tried a lot of workarounds but maybe we missed something?

You could try to create a synthetic nav component.
Add a responsive grid and in each division, add a wrapper component. In each wrapper, put a rich text.
The wrappers will be your buttons. The rich text will be your button labels.
The wrapper interaction for update rows should respect the context of the deck.

Thanks for the reply. I can achieve what I wanted with a button set ok - it works perfectly so your suggestion would work also - I really wanted a simple menu icon and a dropdown that appears on click - like the Nav menu.

I just wondered if it was a bug or similar that it is ignoring context within a deck?