Moving Skuid Page to a Lightning Component

When trying to convert an Account Skuid Page to a Lightning Component, we’re running into the issue of nothing showing up after we click save and preview. 

We have filled out:

Page Name: exact wording for the page name we’re trying to call in Skuid

Page Type: Desktop

Id: Page ID of the Skuid Page we’re trying to call

Page Parameters: We’ve left this blank. Should we be filling it out?

Filters: Blank - should we fill these out?


You can leave everything blank except for Page Name. Page Name is the only one you need to fill out.

I tried that and it still does not pull in anything. 

Any other suggestions?

Also to add more context, we’ve launched it to all users AND saved and clicked preview, and it’s still showing up blank. 

Did you generate a Support File via the ‘More Page Actions’ dropdown on the Skuid page? If you have any javascript in snippets etc. that haven’t been moved to a Support File it can cause the page to showup blank.

I’ve done that - now only half of the page include is showing up. The other is showing blank. Any idea why only half would load?


What’s the content in that part of the page, our of interest? Is it a google map or anything like that? It might be fall afoul of Salesforce’s security policies. Do you have any external javascript resources? I’m guessing it all works when you hit preview.

No googlemap - just a panel set with a few field editors in it (nothing that would warrant a security issue). 

It’s also blank in the preview. I generated a support file for the page, which worked on the other pages, but it didn’t solve the issue. 

Quick Question:  when you type the name of the Skuid Page into the field in the Lightning Component, does it search the name of available Skuid pages?  I’m having the same issue and I feel like yesterday when everything was working, that field searched available Skuid page names.  

Perhaps this is a symptom of the real problem.

Hi Gary, 

No, it’s never searched the name of the skuid page - I’ve always just manually typed it in letter for letter. 

It works fine for Accounts and Opportunities but we’re just having issues with Contacts and Leads.

I just upgraded to the latest release and now this issue has gone away.

The latest release being Millau? We also upgraded to that.