Mobile Skuid - Required Field Missing?

My mobile Skuid page displays a grid of accounts and when you select an account you can select a custom object to view existing records and create a new record.  Existing records are pulling up great but when I click the plus to add a new row, filled out the record and click save I get:

(Regional Office is the field label for the account master-detail relationship).  

Why is this happening?

The underlying model is correctly pulling up existing records which tells me the conditions for the model are correct but when I create a row its not properly setting the master-detail field.  

I was able to work around this issue by adding the Regional Office field to the page, set it to Picklist, set the Option Source to ‘Model’ and the Option Model to the model that has a filterable condition based on the selected account (See image below).  This will properly set the regional office field and the row is saved successfully.  

Do I have to have the regional office (master-detail field) on the page??  

Hi, Peter,
Are you by chance working on the same issue as Brandon Gage’s case? :slight_smile: It sounds very similar!

What conditions do you have on your custom object model for which you are trying to create new records?

Oh funny… I didn’t realize he posted about it too.  Ha!

Rather than having your Condition on Regional_Office__r.Id, have it be on Regional_Office__c. Only fields directly on the current record will be populated by Conditions when creating new records. Notice how in Regional_Office__r.Id, you’re going into the related record to get the Id, but it’s the exact same Id as contained in Regional_Office__c, the foreign key field.

It works!  I swear I tried that but I guess not.  Thanks you guys!