mobile builder cannot add components

Hi,

I’m not sure if it’s just me or doing something wrong, but trying the mobile builder for the 1st time and it seems I cannot add any components…

From what i can see on little training docs there is and some screenshots, it seems when i click on the ‘page panel’ or ‘deck’ , I should be able add components/interactions…

I tried on 3 different browser and that option never shows up…

Any idea why?

Thx

I just tried it on iPhone 6 and it worked. I’m running Skuid 7.31. You should have options. I was unable to recreate a screen without them, so it seems like a glitch to me.

I was trying the Mobile page builder from pc.

But just tried the same on my iphone 6, and i see exactly the same issue…

Go to the Configure section of Skuid and open the “component packs” tab.  Does “MobileCoreComponents” have “active” checked? 


Yes all components are active, including the MobileCoreComponents with load order as 0


I think you either have to double click on the components or drag from the drag handle (three horizontal bars).

I just tried that again on my pc and Iphone and same issue

I tried double clicking the Page panel and The deck and I don’t see options to add components…

Tried dragging as well, with no result

Let me know if want login access to my org


Thx

Hey Dave -

Do you have the tfgComponentPack installed in the org?  if so, make sure it’s set to Desktop only.  The tfgComponent pack doesn’t support mobile and the current version will break the mobile builder.  See the comments starting here http://community.skuid.com/skuid/topics/collapsible-wrappers-similar-to-field-editor-sections?topic….

If this doesn’t resolve the issue, try opening up the developer console and seeing if there are any errors in there when the page loads in the builder itself.

FYI - I just release version 1.3 that should resolve the tfgComponentPack issue in Mobile.  That said, tfgComponentPack does not support Mobile so it should be enabled for desktop only.  See info at http://community.skuid.com/skuid/topics/collapsible-wrapper-custom-component?topic-reply-list%5Bset…

Barry,

You are correct , the culprit was the tfg component, now that i changed it desktop only, i can see and add components!

Thank you


Sorry about that Dave!  The new version should address this issue but even so, make sure to enable for Desktop only.

In the meantime, vote for this http://community.skuid.com/skuid/topics/documentation-for-mobile-custom-components :)