Mobile builder bugs - text field focus problem

When using a SKUID mobile app in an iPad sometimes text input fields freezes and it’s not possible to enter text even though the cursor is in the text field and the on-screen keyboard is displayed. By clicking on another text field and then back to the first field it’s again possible to enter text. One way of making thie problem appear is to drag on the screen outside the field. The cursor is then still in the field when dragging ends but it’s not possible to enter text. Even if clicking in the field again no entry is possible, you must select antoher field first and then back. This applies to Decks in edit mode.

Anothjer way to make the input freeze is in Read with inline editing mode. When double-tapping on a field when the keyboard is visible on the ipad the field changes to edit mode but it’s not possible to enter text. To be able to enter text i must first remove the on-screen keyboard, then single-click in the field and when the keyboard appears again it’s possible to input text again.

All of the above problems exist when running in Salesforce1, both when loading the page with a Tab/Visaulforce page and when loading the page using preview from the editor. Actually I think the inpput box for URL-parameters when doing preview suffers from the same problem.

I also tried viewing the page from Safari but the same probems exist there. And finally I also tried from an android device and that device does not have the same problem when sliding and it automatically hides the keyboard when it’s not possible to enter text. So this might be a iPad/iOS problem.

When using Edit mode pages they switch to inline editing mode when doubletapping on a field and there seems to be no way except save/cancel to go back to Edit mode for the entire page. Is is possible to set a page to only edit mode?

Hi Peter, we are aware of the input / text field focus “freeze” bug, it’s quite annoying, we agree. Interesting that you could not recreate in Android, that might be a good clue for us debugging it further.

Regarding Edit mode, you can set Decks to be in permanent Edit mode, so that you never have to double-tap and even after Saving/Cancelling, the Deck will remain in Edit mode. You do this by going to the Deck’s “Card Properties” area, and there’s a “Default Mode” property that you can set to “Edit”.

That was how I thought it should work, but even if I set default mode to Edit it swtiches to Inline Editing if double-tapping.

and this (old) thread on the Apple dev-forums looks similar. Might be helpful even if it doesn’t have a solution

It’s really very annoying to users and the #1 complaint we got from our pilot users. So hopefully you can find a fix for this.

I’ve done some more testing and it appears the problem is isolated to the iOS/SF1 combination. When using Safari in full browser mode or Chrome on IOS iw works ok. SF1 on Android 4.4 also works ok.

IOS/Safari/SF1 - does not work
IOS/SF1-App - does not work

Hope that helps finding a solution/workaround.

It looks like this is caused by an IOS bug.  There’s a little more info on it here……

and here……

and here…

IOS is not handling input fields in iframes very well at all.  Since Salesforce1 puts Skuid into an iFrame, we have this issue.

From what I’m reading, this will be fixed in IOS 8 which is due out this fall.  If anyone here finds a good solution from doing research on their own, please let us know.