material blue style forcing overflow unnecessarily

Just this morning, Material Blue style sheet starting forcing overflow into “mobile style menu” on third navigational in my app item.  Other styles aren’t doing that and MB didn’t before today.


What version of Skuid are you on? Do you know if anything has changed in your environment recently? An upgrade to Skuid, updating the out of date themes, etc.?

I’m on a developers license on the Brooklyn platform on AWS.  Not sure what version that is.  I haven’t made any changes to themes.  One morning this theme just started working differently, and wrongly in my opinion.

Okay, some more questions to investigate:

  • Is your navigation by itself or in a responsive grid? 
  • Can you post a screenshot of what it looks like? 
  • What’s the behavior of the other themes?

In a responsive grid.
Material Blue with unnecessary “mobile menu” item

Classic - as expected and the way Material Blue worked before the day this started:

There are only these 3 menu items and take up approx. 25% of the available space.
I tried several different themes and they all worked OK except Material Blue.


Alright, I think I know what’s causing your problem. We’ve introduced some improvements to the navigation component to make it more mobile responsive, so that if you run out of space it automatically collapses the navigation items down (though in this case it’s collapsing when you don’t want it to). I think the Material Blue theme has a font size that’s a little bit larger than other themes, and that’s why the MB theme collapses the last navigation item down and other themes don’t. If you set the responsive grid division the navigation is in to “fit to content”, do all the navigation items show?

No.  Get same issue.


Hmm, I thought for sure that would fix your problem. However, I just noticed this property of the navigation component - Overflow to Menu Navigation. If you uncheck that checkbox does your navigation still collapse down?

That makes it work OK but what if I want to use it on a mobile device and want that flag set?  I still think this is a bug.  It worked fine for a long time.