Lookup to object without standard Name field

I’m trying to create a lookup to the standard Salesforce Contract Line Item object, but my lookup returns no results in Skuid.  It works just fine on the standard Salesforce page layout, though.  

I think the issue may be that there isn’t a standard “Name” field associated with this object… it’s identified by the standard autonumber field “LineItemNumber”.  (I suspect this because when I first added the lookup field to my model and reloaded my page, I got an error along these lines - “Skuid looked for field “Name”, but it doesn’t exist.”)

Any ideas for a work-around?  I’ve tried to convert the lookup into a picklist, but that returns blank values as well.  Do I need a custom renderer of some sort?  

I’m also curious to know if others have run into this issue.

K. Not sure what’s going on here.

Firstly, I’d be very surprised that any object doesn’t have the Name field. I’ve seen many instances where the label is something different, but never an object without it.

Also, what do you mean exactly by “I’m trying to create a lookup to the standard Salesforce Contract Line Item object”? Do you mean adding the lookup field ContractLineItem to a component? If so, you could change the fields used to perform the lookup. See below.

To your second question: yes, I’m just trying to drop the lookup field ContractLineItem into the Field Editor component. I just changed the Search Field to PricebookEntry.Name (this is the Product name), but no luck returning results that way either.

To make things even stranger - I just created a model on my page to display all ContractLineItems. They all show up, and the field “Line Item Number” functions like a normal lookup - display name is the Line Item Number; link directs to URL as specified by the ID.

Here are the fields on the Contract Line Item… I don’t think there is a Name field!

Here’s the lookup field in my model:

If I select it (and don’t select additional fields related to it) I get this error message from Skuid:

That is really strange! Well, there’s a always a first. No Name field.

So, you have a model called Cases on the Case object with a Field Editor component o the page which has a lookup field called Product which references ContractLineItem? Now you want to be able to  set the Product based on typing to autocomplete and/or use the popup search? Either way you can set the Search fields on Product as per my post above without issue.

To get rid of the issue you’re having with Product__r.Name. When you select any reference field in a model, Skuid automatically adds the corresponding Name field. So you should have Product__c and Product__r.Name as fields in the model. Remove Product__r.Name and you should be good to go.

Yeah…this is super-strange (thanks for all the help, by the way…). And check this out:

I updated the Search Fields. (By default, it says “searching by name”, so good call to update these.) I started by searching on PricebookEntry.Name only, but that didn’t help…so I added the Id and LineItemNumber.

But every single time I try to populate the lookup, I get this (nothing):

Any more thoughts on this?

hmmm … I’d be quicker to review via screenshare. lemeno if you’d like to review and I’ll provide my join.me URL.

that would be fantastic.  Thank you.  If you still have some time today!

How bout now? I’d like to take a break from what I’m working on anyway.

Sounds good to me!

join.me/mblazonry

Hi Skuid Folks,
Pat and I looked at this together yesterday, and it looks like either a bug… or maybe we call it a really weird exception (no Name field on a Salesforce object) that Skuid has not accounted for.  I can build a model that shows ContractLineItems in a table on my page, but when I try to add a lookup field to the ContractLineItem object, I get no results.  I removed the filter, tried changing the search field, etc… but nothing!  

Thanks for letting us know. This wouldn’t be the first time that standard objects act in very non-standard ways…