Lookup Filters not functioning / no ability to recreate

Hey all!

I use some lookup filters in my Salesforce instance and hoped they’d pull through to my Skuid pages, but that doesn’t seem to be the case. They do work in Salesforce, just not on the related Skuid page. I also tried to use the Lookup filters within the Skuid Page, but they didn’t work either. All of the fields involved are in my two models, and I reference one of the fields I use as a filter as a default value elsewhere, and it shows up as the default value, just doesn’t trigger the filter.

Any direction on troubleshooting lookup filters, or know issues with them, would be greatly appreciated.

I’m on the latest version of the Edinburgh release

Thanks in advance,


Skuid currently does not use the lookup filters defined in your Salesforce configuration.

Our reference fields do allow you to do pretty robust filtering. but that is repeated configuration. I’m sorry about that.

I would be interested in knowing how you are trying to filter your reference field lookup. Because I’ve always been able to build out filtering function in Skuid…

Rob -

I’m trying to limit the results in one lookup field by a value in another lookup field. I’d like my Receiver field to dictate which ‘Ship To Facility’ values show up, and tried this filter out in Skuid:

But even without an entry for Receiver, or with one, I get all the Ship To Facility records back as results:



Are you sure that you are pulling Account__r.Id in your model? Typically you don’t need to do this, and __r references do not pull the Id field by default. Try using “Account__c” instead of “Account__r.Id” perhaps.

Same thing goes for the GC_Customer_Name__r.Id, just change that to GC_Customer_Name__c instead.