Load More does not work with Aggregate Tables

I have a table whose model is an aggregate, it loads all the data up to the limit but load more doesn’t load anything more.

I have this issue since 3 month.Now our product is ready for live but client needs this bug solution before go live.

I am tired now.
Can anyone tell me from skuid team when this bug will resolve?
How much time it takes?
Is there any work ground?

Please provide me your suggestion or answer as soon as possible.

I’m sorry you are tired…  I get tired too when things just won’t work the way I want them too  (or the way my customers expect them to…)

Load more for aggregate models is a pretty thorny problem and we have not been able to fix it.  Yet. 

A workaround may be for you to remove the limit on your model entirely and pull in the full dataset on page load.  
Or you can use filterable conditions to pass some identifyier into the model that will return a subset of data.   (For example:  “Account name starts with:”  and a filter that has A - Z)

Those two should get you going. 


As Rohit mentioned client is refusing to go live unless we fix this issue. This has created a major nightmare for us. I  would appreciate if you could help me clarify following.

1.  Is this a Javascript Memory/Heap limitation issue?  We had a similar issues on other platform and only way they could solve was by moving to C++ for aggregation.  I am worried that if you are running into this fundamental issue with JS, this issue cannot be resolved.

2. What surprises me that you have many clients doing even larger data sets with aggregation. In fact, many of them may be using this for a mission critical. My point is that this must be a critical issue for others too!  How are they able to work around. Workaround that you have suggested doesn’t help in our use cases.

3. How can we deliver a similar function within Salesforce (visualforce, APEX and other). We started with SKUID, so we would appreciate if you could perhaps guide us with a few steps in SF. Even that might be good enough to make our client happy.



Maybe you could describe in more detail you use case.  What are you attempting to show with aggregate models. 

I have two objects one is candidate and other is work experience.

I need to create aggregate report based on candidate but with help of work experience.

So I have used work experience object as base object and create report.

I need to create like below and I also need all the filters.

So I have used work experience aggregate model and create below report.

But now when I am trying to load more it’s not working.

We are facing this issue on all the reports.


  1.  Create Aggregate model and set limit 20.
  2.  Assign that model to any table and add one or two fields in tables.
  3.  add more than 40 records in that object.
  4.  After that you can see load more button.
  5.  Try to click on it.
  6.  It should have to load more 20 records but it is failed to load the record.

Load more is currently not supported on Aggregate models.  You will have to find some other way of presenting slices of the data without using  the “Max # of records” propoerty.   I would suggest using conditions on the Aggregate model that will return a small enough slice of your data to allow it to load without any model limits.  This might be “last name starts with __” or  “Candidate ID starts with __”  These should be set filterable default ON,  so that the page loads with a beginning slice of data.  Then build filters so that the user can select some other slice. 

I believe this is the only way we will be able to satisfy your requirement without a lot of custom code. 

I have tried your suggestion.
I have added three option to select This_Year,This Quarter and Last 2 Year
I have made this quarter as default filter on.
And other as default filter off.

Now when the page is lodes it display only data for this quarter.
After that i am changing filter to This Year at that time both filtes are apply This Quarter and This Year.
So In grid no data display because Both the filters are applied.
So what i have to in that case.

Hi, Rohit,
It sounds like you are activating and deactivating various model conditions with your filter? You will need to make sure you deactivate all other conditions along with activating the condition for the selected filter source. For example, if the user selects “This Year”, deactivate the “This Quarter” condition along with any other date conditions so only a single condition is being applied. Does that answer your question?

How can I deactivate other condition.Can you give me more information for this.
I don’t know how to deactivate other condition when new condition activate.
Some of my condition working Like This_YEAR,THIS_MONTH,THIS_WEEK but Some Conditions are not working like LAST_YEAR,LAST_N_YEARS,LAST_WEEK
I need to know why all this condition which are start with LAST are not working.

Thanks Emily.


Even I am having the same issue, is this bug fixed? As of now I am on SKUID v 6.8.19.
Is this fixed in latest version Banzai?

If not could you please let me know, what would be the work around. I am trying to display data from aggregate tables.

Any help is appreciated.


This has not been fixed in Banzai.  Sorry.  Its a tough problem…


Sorry for the delay. This issue has been resolved in  Rockaway Point Release - Iteration 10 is now available from the Skuid Releases page at http://www.skuid.com/skuidreleases. As always, we recommend testing all changes in a Sandbox instance before rolling out to production.

Thank you for your patience as we got this fixed.