Load Model data on page load and Chatter Feed Component

Since I unchecked “Load Model data on page load” checkbox on my opportunity model the page is loading more quickly but Chatter feed associated to the opportunity model is returning no data.
Could you help ?

I’m not sure, but my guess is that Chatter feeds are tied to records. In order to load a chatter feed, it must know what records to load the feeds for. If you do not load the opportunities model, then it doesn’t know which records to load the feeds for, so it loads none.

Raymond is right.  Cyril you’ll have to load at least one opportunity on page load for the Chatter to work… 

Thank you Raymond, Rob.

Came across this before.

There is a definitive link between the model you have loaded and the chatter feed.

It does not help to have a second model loaded and have that model load data because when you update the model chatter is set to read the data from the first row in a model. So you will not see an update in Chatter.

If you want to show a blank screen and then for whatever reason you have show the data after a certain even then you would probably be looking at a page include option with the ‘Lazy Load’ setting checked.

Added, after you have loaded your page and you update the data you are going to have to refresh the page to see the updated feed.
Alternatively you can run a snippet to periodically refresh the chatter component.

Hope this helps a bit.