Issues with chatter feed

I added a chatter feed to one of my page includes and while it shows the feed, it does not let me interact with it. I can’t post anything and when I click the ‘hide feed’ text, nothing happens.

Here is a gif showing the issue:


A couple of quick questions:

  • What Version of Skuid are you running?
  • Have you tried adding the chatter component directly to the page, rather than in an include to see if you have different results?


I am running 12.2.15.

Strangely, I tested it out on a non page include and it worked.

Is there a way to get it to work on the include?

I have tried reproducing the issue in one of our environments, however, it seems to be working?

Do you mind providing the XML of the pages so I can see where we might differ in setup?

Hi Clark - thanks for responding! Oddly enough, it now works somehow.  I will continue to monitor and let you know if I run into any further issues. Thank you.

Great to hear! 

Just a quick note here for anyone else who is having a similar issue.

When clicking on preview from my edit page, the chatter feature works as expected. When I access a visualforce tab that I created for the page, the chatter feature did not work as expected. 

The skuid page had the checkboxes for “show salesforce header” and “show salesforce sidebar” set to true, but my visualforce page was hiding them.  It appears that both the visualforce page and skuid page need to have identical settings (ie. hide/show sidebar/header) for it to work correctly.