Issues Connecting to MySQL


Trying in Sandbox for the first time to add a New Data Source for MySQL hosted on google, and for some unknown reason, it does not want to work.

I’m able to connect with same credentials Using MySQL Workbench but in Skuid I get an error:

Here are the steps I did:

Added a new CSP Trusted Site with URL:

Created a new Data Source

Type: MySQL / MariaDB

Entered the credentials in all 5 fields

and get the following error:

Anyone have any idea on why, and  how I can make this work?

tested on sandbox Skuid version: 12.2.2 (latest)


Bumped by Error :wink:

I am also having the same issue. Can anyone help me with this.

Hi Dave, what IP addresses have you allowed to access your MySQL database in the Google setup?

The following IP addresses need to be whitelisted.


Hi Ben,

Sorry I was out of the office yesterday.

All IP addresses have been whitelisted from the beginning, so I don’t think that is the issue.

And it cases it helps, when I try to set up the new data source, it does not provide me with the list of IP to whitelist (saw that it’s supposed to do that on Youtube skuid vids and documentation) and directly fails when I try to connect

If you want I can email you the credentials to the SOQL DB hosted on google, as there is only test data in there for now.

Let me know please


Hi Dave, if you want to send the credentials to I can see if I can connect.

just sent, thank you for your help!

Ok after investigating some more, I think I may know what the issue is. It looks like you may have alerted us to a missing section in our documentation. I alerted the docs team and they hope to have something out explaining this in detail in the next few weeks.

In the mean time, you can follow these steps…

  1. Go to Configure -> Data Sources -> Data Services
  2. Click the “Modify JWT Signing Certificate” Button
  3. There are some instructions in that popup that you can follow, but I’ll add some detail as well.
  4. Go do your Certificate Management screen in Salesforce Setup.
  5. Create a new Self-signed certificate, you can call it whatever you want, but SkuidJWTCert is a good name.
  6. Download that certificate to your computer.
  7. Back in the popup (you may need to refresh to see your newly created certificate listed), select the cert you created, and paste the entire contents of the file you downloaded into the text box.
  8. After saving, try creating your MySQL data source again.

Worked like a charm, thank you for your help to both Ben :slight_smile:

Good to know I was not crazy :smiley:

Now that i can connect , will try to understand how to use the data, but should be fairly simple hopefully! 


I also encountered with same problem. As I search for the problem there are many suggestions but not worked any of it. It Will  be helpful if anyone answer me…

Hi Stella did you try the solution above from Ben Hubbard?

Once I followed his instructions it worked fine 

As well make sure you Add a new CSP Trusted Site in SF with URL:

And that your SQL database white list the IP above or allow all IP’s to connect.

Hi Guys,

Everything was working fine(we changed the DB, to PostgreSQL and use SSL and all was working fine) , but now we refreshed our sandbox and tried to connect and no longer works, as well other sandbox I had with active connection no longer works..

Now we get this error when we try new connection and previous one that was working.

Error making proxy request to data source,

in Dev Console it does not not show more than this

Anyone has any ideas please…

Thank you!

did you ever figure this out? Thanks

Hey Arne, yes We have moved to PostgreSQL which was a better fit for us, but at this point have been using it for 5 months+ and it’s behaving properly mostly. If you have a specific issue/question let me know, maybe i can assist

1 Like