Issues connecting to Dynamics365 Online Data Source

This is on the same Skuid Site where this SSO issue was resolved.

No audio in video.


Hi Pat, did you notice if any popups were blocked by your browser? Not Skuid popups, but browser popups related to authentication into the data source. If any were blocked, try unblocking/allowing them, and see if you’re prompted to authenticate into Dynamics365.

I wish it was the case, but alas no. :frowning:

There is an error in the console though.

Pat,

You’re seeing something different than the tutorial because you’re on Skuid Platform. Right the data source creation between Skuid on Salesforce and Skuid Platform is somewhat different (and the tutorial follows the process in Skuid on Salesforce). Our developers are working to make the process the same between the two.

Try using https://your-company-name.dynamics.com/api/data/v8.1/ as the datasource url. 


These URLs produce JSON. But they aren’t working as a Data Source.

https://ip.crm3.dynamics.com/api/data/v8.1 https://ip.crm3.dynamics.com/api/data/v8.2 https://ip.api.crm3.dynamics.com/api/data/v8.1/ https://ip.api.crm3.dynamics.com/api/data/v8.2/

Currently this error.

There was an error enabling the metadata cache: invalid_request

Switching things up I get this error.

There was an error enabling the metadata cache: HTTP Error 401 - Unauthorized: Access is denied

Hmmm, maybe it’s a problem in your authentication provider? Would you mind posting a screenshot of it?

Do you have something like these for your authorize endpoint and token endpoint in your auth provider:

https://login.windows.net/common/oauth2/authorize?resource=https%3A%2F%2Fcompany-name.api.crm.dynamics.com%2F
https://login.windows.net/common/oauth2/token

https://login.microsoftonline.com/ba40b05e-3a37-4407-8584-bb3ac784e3ba/oauth2/token

Hi pat,

One issue I’m seeing with your auth provider is that the token the dynamics server sends you is not added to the request body params (see screenshot which is from a Google auth provider). Meaning that although you authenticated properly the requests you send are still treated as if you were not authenticated because you’re not sending the token along with your request.

I didn’t research the dynamics API doc properly yet for how the server responds with the token but try adding this in for starters and see if this already helps.

Cheers

Hey David,

This really isn’t my wheelhouse. I’m like the janitor in the Nasa control room. “Er … uh … what’s this button do? Dunno but I’m pressing it.” :smiley:

Can you  help me with this?

Pat

Hi Pat,

Sure :slight_smile:

Go to your auth provider and open the section “Common Request Parameters”.
Then click on that rectangular icon (see screenshot) to open the menu and append a new object property to the request header and paste in the following:

Before the “:” paste in Authorization
After the “:” paste in Bearer {{$Auth.Response.Body.access_token}}

Let me know if this works for you. Like I said I’m not a 100% sure if this resolves the issue you’re having but it’s worth a try.
If this doesn’t work I will further investigate how exactly you need to configure this.

Cheers

That part I was able to do before without success. It’s knowing how to troubleshoot this in the first place.

Put me in front of a snippet that’s not working and I’m good to go, but this… I’m lost.

Is there any reason why you chose “SAML 2.0 Bearer Assertion” as “Grant Type” instead of “Authorization Code”? That’s the grant type which is also recommended by the tutorial setup.
And how is your Dynamics API setup (meaning did you set the token endpoint URLs, etc)?

Sorry for asking you those question but it’s hard to exactly know where the issue is :wink:

Consider me the monkey in the control on this. I tried following the tutorial. Didn’t work. Then I tried other combinations of flips and switches since that’s worked for me in the past. It would be better than someone who knows what they are doing actually do this or someone get on a GTM, Skype or Google Hangouts with me to assist. Please. :slight_smile: