Issue with using the Skuid component in Lightning App Builder Pages

Problem: Using the Skuid component in Lightning App Builder pages is currently yielding an error: 

  • A component error has occurred!
  • [There was an error rendering a Skuid Page component for page ___ TypeError: Cannot read property ___]
Who may be affected:
  • Skuid clients using the Skuid component to bring Skuid pages into Lightning App Builder Pages
Who should NOT be affected (please let us know if you are affected!!!):
  • Skuid clients NOT using Lightning
  • Skuid clients using VisualForce to display Skuid pages in Lightning
  1. Create a VisualForce page for your Skuid page as shown here:
  2. Bring that VisualForce page into your Lightning App Builder page as explained here:…
What is being done:
  • Skuid opened a case with Salesforce about this issue. We are working collaboratively to get this issue resolved ASAP.  
  • Skuid product engineering is investigating what Skuid can do.
We will provide updates here.

Thank you for your patience as we work to get this resolved! 

Hi Karen! I hope you’re well.

So this issue doesn’t affect existing pages with a Skuid component already embedded using the Lightning Component? Does it just affect building new pages with the builder? Also, does it affect particular versions of Skuid?

Cheers! Louis

Hi Louis! 

Good, thanks for asking. Hope you are doing well also! 

Customers are reporting problems with existing pages that were being used in production orgs up until they started seeing the errors … 

We have heard reports of clients on multiple versions of 11.2.X and 12.0.X and also a variety of Salesforce NA, EU, and AP Salesforce instances 



Root Cause:

  • A patch released by Salesforce impacted the ability to use the Skuid component on Lightning App Builder pages.
  • Salesforce: We have escalated our case with Salesforce and R&D is investigating.
  • Skuid: Skuid product engineering published a hotfix (Spark 12.0.11 and Millau 11.2.22) that resolves the issue.
What to do if you are affected?
  • Skuid recommends testing the hotfix closest to your current version. These patches are now available on the Skuid Releases page. As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
  • If you are unable to upgrade at this time, please use the workaround offered previously.


I installed the hotfix, but I still don’t see the Skuid Page Component under Custom Components after installing the hotfix. I’ve tried using the Visualforce Component workaround, but it requires that you put in a height (in pixels) of the page which often changes based on the record.

(1) Is there an easy way to make the VF component have a dynamic height based on the page?

(2) Do I need to do something else to use the Skuid Page Component in Lightning Builder?

Hi Sam,

It sounds like you may not have My Domain set up in your org. You can read about this here:

Let us know if this is set up, and you’re still not able to see the Skuid Page Lightning component. 

smh, I had it activated, but forgot to roll it out to users. Now it’s working. Thank you!

Is there a difference in performance (query/load times) with the Visualforce method vs. the Skuid lightning component?


Salesforce released a patch that resolves the issue. If you upgraded your Skuid versions, you are now doubly set :slight_smile:

If you are still affected, please let us know by sending an email to


Hi @“Karen Waldschmitt”,
I am getting this same error this week - perhaps related to SFDC Winter 21 release? Curiously though, System Admin profile is not affected, but all of our other (custom) profiles are getting this error.