Issue with Record Type default value

I am trying to set the default value of the Record Type to None so that the user is forced to choose either “Officer/Director” or “Other Contact”. There are only 2 record types used for this custom object. I have tried adding a third record type of “none” and having it to default to that, but it is not working either. Also, there is a problem that the dropdown for Record Type ID is showing “Officer/Director” twice in the list (see image). Thanks in advance for any assistance.

Is the record type assigned to the user’s profile?

Those record types in the image are on the custom object and they relate an existing contact to a holding company. A contact can serve on many holding companies as either an “officer/director” or “other contact.”   They are not related to a user profile, so far as I can tell

All record types get assigned to profiles. Go to create another record type and you’ll see a step in the process that you select which profiles to assign it to. Alternatively you can open any profile and go to the object to see which record types it’s assigned.

Yes, the record type is assigned to profile. (see image)

Hmmm… Sorry. Didn’t read your original post entirely.

Once you place your Record Type field on the page you can set to render as a picklist, required and with the option to add “None”. Seemingly this is what you’ve done. What version of Skuid are you running? Can you post your XML for the page here?

Thanks for you assistance Pat - Here is the XML. We are using Skuid version 9.3.4.

{{Name}} {{Model.label}}
{{Name}} {{Model.label}}

Not sure what happened in your page, but it simply wasn’t working. On rare occasion, the XML and the settings in the page builder aren’t in sync.

That said, I removed the field and added it back in with the options I mentioned earlier. I then added a condition that ensured there wasn’t a record type auto selected.

Well thank you again Pat, I will give that a try. 

I got it to work! Thanks again for your help.