Inline Record Creation not saving new record

We have a View/Edit Action for our Account object and a related child object using the following Model Condition: http://cl.ly/image/001b150m3F33. When a user attempts to create a new inline record on the child object, the record saves…but without any link to the parent Account. Any suggestions? Thanks.


My guess is that the param condition is not really getting set. 

You might try to change the value type to “field from another model” and select the Account Model and ID field. 

Or… make sure that the Parameter value is correct - it is case sensitive.  Maybe you are passing in “Id” instead of “id”   Hard to see,  easy to mess up…

Thanks for the quick response. We have tried both approaches here, but both result in a record being saved, but not connected to the Account. And there are no errors on saving the record. Anything else we can confirm on permissions, etc? Thanks again.

Could this be one of those ones where you don’t need to traverse the related field, so remove the ‘.’ in Account__r.Id  ?

ie the condition should just be the reference field, so in this case “Account__c = param(id)”

That was it. Thanks much!

Glad to hear it worked. I’m usually the one being helped so its nice to help someone else out!!

Thanks Greg.  Appreciate your help.