Image not displaying in Partners Page

I have a simple image (company logo) in the corner of my page. When I preview the page, the image appears normally:

However, when I login as a partner/vendor, the image will not display:

I believe I’m using the correct HTML coding:

Anyone have an idea as to why this is happening?

Hi scott,

Looks like you are using an image stored in salesforce

Make sure the checkbox : “Externally Available Image” is checked and checkbox “Internal Use Only” is unchecked in the document record where image is stored

Or store the image somewhere else and use a url instead

Hope it helps

To add on to what Dave said, these issues are usually 1 of 2 things.

1. Access. Your users don’t have access to view that file in Salesforce.

2. Url. Sometimes you need to prepend your site prefix to the beginning of the url when you’re in the context of a site.

All of my images are stored in the File object.  How do I access the “Externally Available Image” checkbox?

I assumed Image was stored in “Documents” not files. This is still the recommended way if you want to have image available to Non-Users

If for users , you can use file and change the Sharing Settings

and then changing permissions for “any user in your company” to “viewers”