Image in formula fields

Hello, 

I’m trying to present the formula field on skuid table that is in text form and shows images based on different criteria of another field. On SF it is working correctly. However, on Skuid it only shows alternative text and icon of the picture. 

I also used template and “allow html” but it didn’t help. Should I use another approach for such situation?

Thank you

This should work fine in Skuid. I have a Formula(Text) field that returns a static resource image. I am able to display the image in a Skuid table or Field Editor just fine. Can you paste your formula here? How about a screenshot of the table? Does the formula field display as STRING in the table composer view?

Jakub,

What is the value of your src attribute on the resulting image tag? If you copy/paste that into a new tab, does the image show?

Hello, thanks for all replies. More details from what I get:

a) the table has shows the string field (the formula is string).

as you see it is not showing images;

b) the formula itself in standard SF layout is working, please find the screen

c) the formula values are:
IF (ISPICKVAL( Relationship_Force_Level__c, “1 - barely known”), IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”, “Star”),
IF (ISPICKVAL( Relationship_Force_Level__c, “2 - business connection”), IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”, “Star”) & " " & IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”, “Star”),
IF (ISPICKVAL( Relationship_Force_Level__c, “3 - business and private connection”), IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”, “Star”) & " " & IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”, “Star”)& " " & IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”, “Star”),“Select Level of Relationship”)))

d) url in another tab is working ok (I mean when I viewed this file).

What do you think?

First.  IMAGE formula fields will work in Skuid.  I’ve just tested this again and just by adding the formula field to your skuid talbe (or field editor) you will get the Image.  There has to be somthing strange going on here. 

There is a problem in your formula fields that is pretty strange.   You need to add a leading “/” to your IMAGE definition. 

Instead of IMAGE(“servlet/servlet.FileDownload?file=01524000000AJGm”  
It should be: IMAGE("/servlet/servlet.FileDownload?file=01524000000AJGm"

This is the way Salesforce suggests that image formulas be constructed,  and while the “no slash” model works in standard layouts - it doesn’t work in Skuid. 

Hopefully this works for you. 


Rob, thank you. It works.