How to update # of Decimal Places for Field


I am trying to set the number fields in my tables to 0 decimal places, and it seems there should be an easy declarative way to do so because there is a field for it in the UI, but the only option in the field is “Use Field Metadata”, but we do not want to update the field in Salesforce, just in this Skuid Page. Seems like a possible bug?


Hi Smdrich,

Try updating the decimal places in the settings for the field on the model, instead of on the table. In that view you should be able to check the “override field metadata” box and change the decimal place length from there.

Thanks, Elena.

That worked for the fields. In order to do it for the aggregation fields I had to create a UI-Only forumla field and use the Round function to re-display the aggregation field.

I still haven’t figured out how to adjust the decimals in the column summaries, though.

Hey @Smdrich are you using v1? What version of Skuid are you using?

Testing v1 in Spark Update 3 (12.4) we are able to set the field # of decimal places in the table and it affected the column summary as well.


I think @Smdrich is using v2, but I might be wrong.

Not sure why @Smdrich is not getting to choose number of decimal place, though even if @Smdrich was able to select how many decimal places he wanted to display it still wouldn’t work. It seems like some of attributes of Table Fields are ignored, there might be more but I found that ‘# of decimal places’ and ‘Allow Sorting’ are not working/ignored.

‘Allow sorting’ is ignored per column case, meaning either sorting is enabled for all column or none. Also, Sorting text area is allowed, and if the sorting is happening on server this throws an error (SF cannot sort text area fields), and this error makes Skuid pages crash every time the table is loaded because the sort option is saved. Another issue is when fields Id has spaces in them, the icon for sorting is shown but its not working.

@Smdrich Thank you for sharing the work around.

Skuid V2, 13.0.15