How long does it generally take to generate support files?

How long does it generally take to generate support files? I know that it takes some time but it has been running for over an hour and has not changed.

Spencer~

I’m not sure I’m following what you are trying to do. Can you provide a little more detail? What support files are you trying to generate? How are you trying to generate them? 

Thanks!
Karen

Spencer, 

I’m not sure about the max amount of time it should take, but I don’t think it should take over an hour. We have documentation here that contains a little more detail about generating support files. Are you generating support files for all of your pages or for one individual page?

I’m having a similar issue - it’s been hanging for over an hour now. I might try closing the tab and producing the files in smaller batches… If I quit the hanging tab will I run the risk of any irreversible damage?

Cheers!

Louis

If it helps, I’ve got a readout here from the console on the hanging page:

I think it would be a really good idea to try generating the files in smaller batches, and it shouldn’t do any (irreversible or otherwise) damage to quit the hanging tab.

Hi Amy, I’ve given that a go, but even with one new page with nothing but a query, a table and a snippet with a simple variable assignment it’s hanging with the following error in the console:

I’m on 10.0.0.1. I’ve tried this in some other orgs without issue…

Ta!

Where are you generating the support file from? The page itself, the Skuid Pages List page, or the Generate Support Files for All Pages button under configure -> Page Support Files?

I’m getting the same result with all three methods. I’ve just tried it from the page itself.

I’ve granted login access in case anyone wants to take a look. The page I’m testing it on is ‘test-pagepack’, although I’m getting the same result across other pages. Apologies if I’ve done something wrong!

Spencer and Louis,

Our developers have been able to reproduce this problem and are now working on a fix. We’ll let you know when a release is available that fixes this.

Thanks!

Hello Skuid Community ~

Thank you for your patience! Skuid implemented a fix in the new Brooklyn (10.0.3) release which is now available on the Skuid Releases page.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.

Nice one! That’s fixed it for me! :slight_smile: