How do I get the User filter to work on the Aggregation Case Study documentation

I have followed the instruction on the Aggregation Case Study documentation and I cannot get the Oppty Owner filter to work on the Opportunity table. First, it is not rendering as as a drop-down list - because there are so many records - and second, the filter does not seem to be recognizing the condition on the User model. I even added a 2nd condition to show only Users with a specific Manager. When I add the User model as a table, I only see a handful of Users as expected, but when I look in the User filter it shows all users even though the datasource is set as the User table. Is there something I am doing wrong? I have checked and re-checked to make sure that I am following the instructions - and I am.

I am working in V2

Here is the link to the instructions https://docs.skuid.com/platform/v1/en/skuid/models/aggregate-model/aggregate-model-use-case.html

Here is the XML

<skuid__page unsavedchangeswarning=“yes” personalizationmode=“server” showsidebar=“true” showheader=“true”>

<skuid__table model=“Opportunities” uniqueid=“sk-ah8-8224” mode=“readonly”>

<skuid__filter uniqueId=“sk-alq-19061” type=“select” conditionSource=“manual” filterMethod=“server” labelMode=“manual” label=“Closed Date” createFilterOffOption=“true” conditionName=“CloseDate” filterOffOptionLabel=“Any Closed Date”>

</skuid__filter>

<skuid__filter uniqueId=“sk-b3G-31548” type=“multiselect” conditionSource=“auto” filterMethod=“server” labelMode=“auto” conditionOperator=“in” conditionField=“Account.Industry” conditionName=“__autofilter__Account.Industry”>

</skuid__filter>

<skuid__filter uniqueId=“sk-c3m-10083” type=“select” conditionSource=“manual” filterMethod=“server” labelMode=“manual” label="Opportunity Owner " conditionName=“OwnerId” createFilterOffOption=“true” filterOffOptionLabel=“Any Owner”>

</skuid__filter>

</skuid__table>

<skuid__table model=“Users” uniqueid=“sk-baM-5032” mode=“read” title=“Portfolio Managers”>

</skuid__table>

</skuid__page>

The user filter should render as a dropdown as is. I tried the same using standard fields and get the same result as you.

<skuid__page unsavedchangeswarning=“yes” personalizationmode=“server” showsidebar=“true” showheader=“true”>

<skuid__table model=“Opportunities” uniqueid=“sk-ah8-8224” mode=“readonly”>

<skuid__filter uniqueId=“sk-alq-19061” type=“select” conditionSource=“manual” filterMethod=“server” labelMode=“manual” label=“Closed Date” createFilterOffOption=“true” conditionName=“CloseDate” filterOffOptionLabel=“None Selected”>

</skuid__filter>

<skuid__filter uniqueId=“sk-c3m-10083” type=“select” conditionSource=“manual” filterMethod=“server” labelMode=“manual” label="Opportunity Owner " conditionName=“OwnerId” createFilterOffOption=“true” filterOffOptionLabel=“Any Owner” rememberInPersonalization=“false”>

</skuid__filter>

<skuid__filter uniqueId=“sk-b3G-31548” type=“multiselect” conditionSource=“auto” filterMethod=“server” labelMode=“auto” conditionOperator=“in” conditionField=“Account.Industry” conditionName=“__autofilter__Account.Industry”>

</skuid__filter>

</skuid__table>

<skuid__table model=“Users” uniqueid=“sk-baM-5032” mode=“read” title=“Portfolio Managers”>

</skuid__table>

</skuid__page>

  • Hi Monica, are you still experiencing issues with this user filter?

    What version of Skuid are you using?

  • I copy and pasted Pat's XML into an org on the most recent version of Skuid (13.0.8) and the user filter works as expected.

You can use this setting to choose at what point the filter should switch from a dropdown list to an autocomplete.