hide empty segment in a donut chart


The short answer is that Charts show whatever is in your model data, so if it’s in the model, even with a zero value, it’ll still show. The only way to get rid of them without writing some code at this point is to not have them included in your model. If that’s not an option, you can use a Before Render Snippet (see this and this for some good community resources) to remove the series that you don’t want shown.