Has anyone gotten global search on a postgres datasource working?

I can’t seem to get it to work, since I keep getting these errors with any setup using the Search component. Working on AWS’s RDS if that’s relevant, with a repro page below giving a better step by step of what I’m seeing. I tried on a simple table with two fields (id, name), and both are marked as filterable after the initial import into Skuid.

<skuid__page unsavedchangeswarning="yes" personalizationmode="server" showsidebar="false" showheader="false">
		<skuid__text contents="Repro Steps:&lt;br /&gt;&#10;(Setup)&lt;br /&gt;&#10;- Have a postgres table with two columns&lt;br /&gt;&#10;1. name: id&lt;br /&gt;&#10;type: uuid&lt;br /&gt;&#10;default:&amp;nbsp;gen_random_uuid()&lt;br /&gt;&#10;2. name: name&lt;br /&gt;&#10;type: character varying&lt;br /&gt;&#10;- Have datasource imported to Skuid with id marked as id Field, name marked as name, and both filtertable&lt;br /&gt;&#10;- Select that entity in the search component below for the Return Object&lt;br /&gt;&#10;(Steps start here)&lt;br /&gt;&#10;1. Preview the page&lt;br /&gt;&#10;2. In the search, type in 6-7 characters&lt;br /&gt;&#10;3. Delete a few characters&lt;br /&gt;&#10;&lt;strong&gt;Expected result&lt;/strong&gt;: Search results show based on characters&lt;br /&gt;&#10;&lt;strong&gt;Actual result&lt;/strong&gt;:&amp;nbsp;There was an error performing the query on Model search__AWS_RDS_Skills__quickTest_public--2e304de8-7395-4dc0-b151-47e9b4c4984e: Invalid Condition Logic&lt;br /&gt;&#10;4. In the builder, add id to the fields for the Return Object in the search&lt;br /&gt;&#10;5. Save &amp;amp; Preview&lt;br /&gt;&#10;6. Type 6-7 characters in the search&lt;br /&gt;&#10;&lt;strong&gt;Expected result&lt;/strong&gt;: Search results show based on characters&lt;br /&gt;&#10;&lt;strong&gt;Actual result&lt;/strong&gt;:&amp;nbsp;1. There was an error performing the query on Model search__AWS_RDS_Skills__quickTest_public--cf410a7d-9f4f-49b3-8c73-0c4fda99201a: Invalid Condition Logic&lt;br /&gt;&#10;2. There was an error making a request against the database: function lower(uuid) does not exist&lt;br /&gt;&#10;3. There was an error making a request against the database: operator does not exist: uuid ~~* unknown" uniqueid="sk-2sjL-20121"/>
		<skuid__search uniqueid="sk-2sj6-18024" tokenizeSearch="false">
				<object datasource="AWS_RDS_Skills" id="quickTest_public" fields="id">
						<action label="cheese toastie" icon="sk-webicon-ink:toast">
								<action type="showToast" duration="4" position="bl" message="id {{id}} name {{name}}"/>
						<field id="name"/>
						<field id="id"/>
		<styleitem type="background" bgtype="none"/>

Thanks for joining the community Matt. Hope all is well in new projects.

I’m finding a problematic query getting constructed by our search component here. The Condition logic is problematic and the query fails about 75% of the time. I think its a bug and have reported it as such. We’re taking a look.

I think workarounds like using a filterset or a form with a reference field might work. But you’ve probably already gotten that far.

Let me know if you’ve got further questions.

Thanks Rob! Makes sense. It has worked fine from a filter set, but I was working on a global search with a few different objects. For now I’ll push that back since I don’t think a DIY version of it is worth the amount of work that component saves us…