Global Actions list showing first item as default

I’ve set up all my “Gobal Actions” menus so that “Use first item as default selection” Is unchecked.  However, this setting doesn’t seem to be respected - I’m seeing the first item as the default menu item throughout my org.  Any ideas about why this might be happening?  

Could you elaborate on what your set up is and expound upon what you’re seeing? Pictures are wonderful

Here are my settings:

And here’s what the Mass Action picklist looks like:

Based on my settings, I would have expected the picklist label to say “Manage Selected”, and then have “Add Nurse Coverage” as the first item in the menu. (It did work that way at one point!)

What version of Skuid are you on? I haven’t been able to reproduce the problem on 9.5.4

9.3.4 - I’ll see if an upgrade will solve this!

I highly recommend sandbox first, testing it, then production

Installed in the sandbox and updated themes, but no luck!  I also tried removing and re-adding the mass actions, but that won’t do it either.

Are you able to change it at all or will it always have Add Nurse Coverage? I think I’m running into a bug where it won’t change after it has been decided. It’s like you get one change and then it doesn’t matter after that

I can completely remove it, but no - I can’t change it.  I also tried to edit the XML, but that’s not working either

I have been able to reproduce your issue for the most part. It does seem to have something to do with upgrading. However, if I go into the XML and search for the title, I can edit it and the edit will be respected. Could you paste in your broken XML that isn’t working?















CasesToCover














Select Nurse:

























CasesToCover



















CasesToCoverStorage
















CasesToCover


















Select Admin:

















Sorry - that’s a giant mess! I think this is the most import part:


Stephen, any updates or further thoughts on this?

I have notified our development team of the bug and we’re currently working on getting a fix out in an upcoming release of Skuid

Good news - thank you!

Hi Elissa,

Skuid has provided a fix that may be related to your problem in our Brooklyn 10.0.21 and Millau 11.1.8 releases, which is now available on the Skuid Releases page. The issue is labeled [CORE-1072] - Title of Mass Action and Global Action Incorrectly Synced - Button Label Not Applied. If you are still experiencing this problem, you may want to consider upgrading to either of these versions and see if the issue is resolved.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.