Getting error - 'DataSource' of undefined for one of the user's in salesforce org

One of the user’s in our salesforce org is getting the following error. Skuid version being used is 9.5.2 and I have even upgraded to 9.5.6 but the error persists

I am also getting same error…gettin this error when creating rows for OpportunityContactRole object.

Hi Sneha, if there’s only one affected user, the issue could be related to the user’s own environment - i.e. their computer, browser, local intranet content filter, etc. Have you tried reproducing the issue with the user on another computer and another browser?

Neena, do you see the issue with multiple users? If so, do you recognize a pattern or attribute common to all affected users? 

In looking for information about this error message, I came across this Salesforce known issue (which was resolved in Spring '17). It mentions that the behavior is expected if you have “Content Sniffing Protection” enabled in Salesforce, so that may be something to check into. 

Hi Mark,

The error is not consistant, we have 2 full sandboxes, both on CS59. Getting error in one sandbox where as the same script works fine on other. Both sandboxes were recently updated with Brooklyn release.


Hi Neena and Sneha - have you checked to see whether Content Sniffing Protection is enabled in the affected sandbox, as mentioned in the Salesforce known issue linked above? 

Hi Mark, the sandbox which has the error is summer 17, still we have the issue and is common to all users. And also Content Sniffing Protection is not enabled.

Can you share a screenshot of the full console error that you’re seeing?