Fontawesome icons for Partner/Customer Community Users

We were super excited to roll out the “Banzai’d” version of our Skuid pages…only to have our dreams crushed when we discovered that the Fontawesome icons appear to be broken for our Partner/Community users. I suspect that this has something to do with their access to static resources in SF. Is there a solution? Here is what’s happening: Working just fine for internal users - Fontawesome icons appear broken for Partner/Community Users -

SOLVED! Since Partner/Community Users don’t often have access to Static Resources, you will need add a link to the font-awesome webfonts to the css of your page.

Glad you got this fixed.  Thanks for documenting your fix for posterity. 

Gary, what version of Skuid are you running? If you’re not using the latest version, try installing it from the Skuid Releases page, and then try removing your external resource load, that may fix it as well.

I am having the same problem on a site. It can’t load these files:

It appears that the name of the Site is missing. These URLs should be:

Other resources have the correct URL like:


I was not able to fix this as Gary did, but maybe I just need a better URL for the webfont.

FYI I am on Skuid 7.7.


Tony.  I would upgrade your version of Skuid.  We took care of some of the CORS issues with loading Font Awesome after 7.7 

I installed Skuid 7.16 and still am getting the same problems. Still trying to download font Awesome from the same URLs that give an error.

I am experiencing the same issue with Community logins not seeing the icons. I have installed the latest version of Skuid but the icons still don’t show up. Is there an external link that will work?

Gary can you provide the full url that you used?

Tami / Tony, can you Grant Login Access to Skuid Support and email us your org Ids? I am not seeing this in our test orgs for Community functionality.

I’m not sure if my solution is the correct one, but it definitely works.  I’m on Skuid 7.16.  

The full url that I put in the parent tab page is:


Also, just as a test (since I have upgraded my version of Skuid since I first posted this), I removed my external resource link to the FontAwesome resource and the FontAwesome icons no longer worked for my partner users.  

Zach I have granted you login access and emailed you the org Id. Thanks!

That worked! Thanks


As an FYI Gary’s solution works the icons are brought it but only with adding the external url.

Sent you the org ID and granted access.

Tami - what external URL did you use?


Gary provided the URL he used: 


For anyone experiencing this issue, here is what we recommend: go to the Skuid Releases page, install Banzai Update 3, and then once it is installed, go to the “Theme” tab, and if you are using custom Themes, click “Update Out of Date Themes”. This should resolve the issue.

The upgrade worked on standard themes but not on my custom theme, even after I did “Update Out of Date Themes”. I went into the custom theme and clicked save and that fixed the problem.

Thanks so much for fixing this problem!

This update has fixed the icon issue. Tony thanks for the saving tip!