File Component Not Attaching Uploads

I have a Skuid Page with a Task object model. I would like to allow the user to upload attachments on the Task. I followed this tutorial to the ‘t’ and and launch the page directly from skuid, it works at first, but as soon as I start adding other components (tabs, editors, etc) to the page it stops working. When I try to upload, I can select a file and it seems to be working, but the file never uploads. If I try to embed the Skuid Page in VF then it completely stops working. When I click the button, nothing happens and there are no JS errors. I also tried followed the tutorial on putting the button directly in the table but that doesn’t work either. Everything seems to go well, but when you are returned to the page the file isn’t attached to the Task.

I think you’re experiencing 2 separate issues here, one of which is a recently-identified bug we’re working to address, and the other of which can be quickly fixed. Issue 1: a User can only use the File component to add Attachments to Tasks that that User is the Owner of. Issue 2: for the Skuid File component to work when Skuid is run from a VF page (using the skuid:page VF component), you have to make a local clone of the UploadImage VF Page that is in the SKuid Managed Package Looks like this is not in the tutorial for the File Component, but it should be. We’ll address this. There are actually 4 Visualforce Pages that are included in the Skuid Managed Package that you should make local clones of if you are going to use the skuid:page Visualforce component. These pages are: - ExportData - Include - UploadImage - Social To clone these pages, simply go to Setup > Visualforce Pages, and find each of these pages. Click to view each of them, and copy and paste the Visualforce Markup of each, exactly, into a new Visualforce Page with the EXACT same name and label, like so: Once you’ve saved each page, click “Security” next to it from the Pages list view to make sure that all Profiles can see it.

When I try to save Include I get the following error:

Error: Method is not visible: [skuid.Ui].getLabels() 

Maybe I’m working on a older version? Looks like I’m on 3.14. Also if I try it with just the other 3 pages copied it does seem to actually upload the file and attach it to the task, but it doesn’t update the table component below (same as tutorial) until i refresh the page.

Yeah that error message has been fixed, I would install version 3.22 of Skuid:

Well, that seemed to work, but also made me realize this approach will be a headache to maintain. Every time a new update comes out someone (hopefully not me) will have to check for changes on those 4 pages and manually update them. I might try the global action on table approach, again. Maybe it wasn’t working before because my user wasn’t the record owner?

We are committed to not making any changes that would cause the functionality of those 4 “local” pages not to work — if we did something to stop them from working, this would affect us internally as well as our customers, so this would be a no-go. The global action on table approach sends users to a standard Add Attachment page.

Are these both still issues in v5.8 of Skuid? I’m in the same boat of trying both ways of enabling an attachment to a record created and not getting anywhere (I don’t even get the name of file being uploaded shown in the box that appears in the screenshot originally submitted).

I don’t see any mention of cloning the VF pages in the tutorials so hoping this is fixed…and wondering why it isn’t working for me.

The issue with having to clone the VF pages to your local namespace if you are using the “Skuid:page component” method of doing overrides is still in place.   See the instruction on using that methodd.…

Are you sure that your issues are the same?   What model is the “Parent” model for the file component? 

Perhaps my situation is having a more basic problem with the upload. I am just using the preview function to test. I haven’t done the overriding yet.

I have tried two custom objects as parent model (both being created in a wizard), one has a field for file and the other I’ve been trying to attach the file to the record. Even when saving the custom objects before going to last page of wizard (with file upload), I can’t get it to actually save the file or even show that it is uploading it (shows the upload button but never goes away or finishes). I have tried just a file component on the last page and also the file component with a table to view what is uploaded.

Might you grant us login rights to your org so we can take a look?   Use this tutorial:…    Then send an email to “” with your Org ID and the name of the page where this is happening. 


Done earlier today.

Chris.  Our file component has not been updated to work with new file creation processes.  It has to be loaded into a page where there is an existing parent record in context.  Even when you use the action framework to save the Art_work record before moving to the attachment step it will not work.  We know there are things we need to update about the File component…

So - I’d suggest you do have a two page process - where after filling out the art work and grant details,  the page saves and redirects to a second page where the attachments can be added.    Or put the attachment part of the process in a page include that is lazy loaded on the appropriate wizard step (This page would also need an “art” model). 

Hopefully this gives you some direction. 
Sorry for the run around. 

PS - would love to know more about your project.  It seems really cool. 

Rob, thanks for this clarification…and wow…I really wish that were documented somewhere. I’ve wasted a lot of hours trying to get that to work. In fact, it’s probably 3/4 of the time I’ve put into the trial trying to make a proof of concept for an application tool. 

I haven’t even seen this component working so I’m not even sure if it does what I need. I’m wanting to have a page with 3 file upload fields/buttons. One of them will be required. Is that even possible?

Would be good to mention in the wizard that you can’t use a file component directly (sounds like what you are saying).

Ok, so I think I am starting to see the limitations of file component you were referring to (but I still can’t get it working in any way as per use case or in a way that I would think is an acceptable user experience, so perhaps it isn’t working yet). I have an upload to a field partially working now (it will insert into a field, but after an ugly upload experience), but can’t get an upload to attach to a record. Any advice appreciated.

My understanding:
First, the file component adds an upload button and that button just let’s you keep uploading…could be adding new attachments if you are attaching to record or replacing the attachment for a field, if inserting to a field. Is that correct?

Second, it seems that you have to have a second component on the page to actually complete the upload, since the name is required and that isn’t requested in the file upload. ie the addition of the table component on the page. It was really unexpected to have to upload and get an error on saving and then edit the name via the table.

My desired use:
I’m trying to create a UI where the user is present 3 upload fields and must upload at least 1. Is this possible?

I am still running in to this issue. Getting the same error message as the original poster. I am working in the sandbox, and I am only trying to attach files to records I own. 

What else could be causing the issue? How do I know if I am on the most recent version of SKUID?

Justin, the OP didn’t post an Error message - it was just a silent failure.  Are you getting a specific message? 

To see your current version of skuid go to  Setup  -  Installed Packages - and look for Skuid in the list.   Current version is 6.8.14.  You can load that version from

I have updated to the newest version. I am still getting the silent error when I run it in preview mode. It just says “Uploading” forever. Thoughts?

Would you mind giving us login rights to your org so we can take a look at what is going on?   Here is how: 

1. Use this tutorial to give us login rights:…

2. Then send an email to  with your org Id and the name of the page where the problem is happening, and the steps required to reproduce the problem.  

We’ll see what’s going on…