Field not showing in table

Hi everyone.

I’m not sure why but I have a field inside a model not showing in my table. I have added it and the model is correct. 

Other fields from the model are visible and look all good. Anyone have any suggestions as to why? 

Hi Matt, does the table have a place for this missing field, or is there not even a header? If the field is missing altogether, I would check to see if that field’s permission and sharing settings are set up properly. 

You might also try putting the same field into other components like a field editor or template, to see if the issue is specific to the table, or occurring whenever the page is trying to expose that field. 

Finally, there’s a chance the field’s column in the table has a render condition set up on it that’s not being met. You can see this in the page composer by clicking the field in the table, then clicking “Rendering” toward the top right corner of the page. 

Hi Mark,

Thanks for the speedy response. 

I had checked all the obvious stuff like field permissions and rending conditions. There is most definitely a field header visible in the editor. 

I’ve also tried with another table and still no luck. =(

What is the API name of the field that’s not displaying? Have you confirmed that it has data for the records that you’re loading?

Is the field set up as a template field perhaps? If that’s the case, the template field needs to be defined otherwise it won’t know what content to display. (more information here)

Ok team I have an update. 

Turns out I believe this was a bug. We ended up adding the field again via the XML and it worked fine. 

As far as the Salesforce side was concerned it played no role in the field not being visible. 
I think Skuid should probably investigate why this bug happened. 

Thanks for all your help and suggestions. 

I’m glad you were able to resolve your issue. We would definitely want to investigate any possible reproducible product defects. Would you be able to provide any more details to help us reproduce the issue?

The table was referring a normal model that was linked to a custom object. The table was also within a tabset. Everything here was standard. No renderin conditions. What other information would you like?

Do you need the xml? 

Hi Matt, 

If you still have a way of retrieving the XML as it was before you fixed the issue, it would be informative to see the two side by side - at least, the parts of the XML where you needed to make your changes. If that’s not possible, we may just need to revisit this if the issue recurs since there isn’t quite enough information to be able to reproduce the issue. 

If you can try adding the field to a new page from inside the Page Composer (not via XML), and let us know if the issue presents itself again, that will be helpful too. 

Hi Mark, 

I don’t have enough save history to retrieve the previous XML on the page unfortuantely. ** This would also be handy for skuid to possibly double the save version history.  

If I come across the issue again I will let you know and provide the XML for Skuid to take a look at it. 

Hi Matt, thanks. There’s actually a way to set a page’s max number of auto-saves to whatever you want, available in the Page Properties area. It’s set to 25 by default so your page records don’t get too large, but I’ll often set it much higher.

Oh wow great!   I didn’t know this. 

Thanks a million!

Hi @Matt Small – can you elaborate on how you added the field again via xml?  I’m having a similar issue but it’s only affecting one user so I’d hate to impact the other users.  Thanks in advance!

  1. In page composer, go to the bottom right hand corner where it says View/Edit XML.
  2. Find the model you're looking to add the field to. You could Ctrl+F and paste the model name, since in the XML models are listed at the top.
  3. Where you see through those are the fields in the model
  4. Any where in that list type and you're good to go
Just remember the __c for custom fields

Custom Fields
Standard Fields