Error: Unable to retrieve labels

Our Salesforce home page has a Skuid Page lightning component. Starting this morning, our users are seeing this error for 3 seconds each time they visit or reload the Salesforce home page.

Skuid: Unable to retrieve labels
The following requested labels could not be retrieved: [long list of labels]

I tested by switching the Skuid page referenced by the lightning component, and the error occurs with any Skuid page. If I remove the reference to the Skuid page, but leave the Skuid Page lightning component on the page, the error doesn’t occur.

I haven’t seen the error occur on Skuid pages that are not embedded in a lightning component.

When I logged in this morning, I didn’t see the error right away. We just updated to Salesforce Winter '19, and I was prompted to try the new cozy/compact display density feature. Once I tried that, I got this error.

Skuid 11.0.3

Bueller? Bueller? Bueller?

I tested updating sandbox to Millau 11.2.10, but the error ‘Unable to retrieve labels’ still happens.


Thank you for alerting us of this issue. Another client has also reported this and we have been engaging Salesforce about it as we are unable to reproduce this in our own orgs. We will update you on how that gets resolved.


Hi Karen,

Is there any update on this issue? We are also experiencing the problem displaying a Skuid page within a lightning component. Thanks!

My update to 11.2.11 fixed it. Actually, I think the update to 11.2.10 fixed it as well, but at that time I still saw the error due to caching. I apologize, but I forgot to update this thread at the time.

Thanks, Tim! We will go ahead and update.