Error on SKUID builder after refresh of sandbox

We did our sandbox refresh and facing following error on the skuid app.

An error occurred while attempting to load the “skuidcore” Component Pack. There may be an issue with the name or location of your Component Pack manifest files. Error: Please check Skuid Settings to ensure that this Component Pack has been correctly requested.

It looks like the SkuidCore component pack did not get correctly installed in that sandbox on its refresh. Can you go to Skuid settings page, and look for the component packs Tab. Does your definition look like this?

Please note that I have the additional properties drawer open here.

Hello Rob

I am not able to go on the skuid setting page. the same error message displayed

Yup, if the skuid core component pack is not installed you won’t be able to load any Skuid page - including Skuid Settings. Sorry.

You will have to go into setup and set up the component pack there. Here is how:

  • Go to Setup - Develop - Custom Settings.
  • Select the Manage link next to the “Component Pack”

The Sandbox Refresh removed the component packs. You need to add the skuidcore and skuidmobilecore set of data.

Below is an image of the fields you need to add to the new record for the skuidcore component pack.

You will need to do the same for the mobile core and for visualizations. You can find these custom settings in another org and copy them from there.

Let me know if this works for you.

Thanks Rob

It worked for me but i don’t see the pages getting copied over to SB from Prod :frowning:

Please advise

It seems that you don’t have a full copy sandbox. This is why the refresh didn’t copy the custom settings.  (Which under the covers are just data).  Skuid pages are also just data.   You will have to migrate that data from Production down to the sandbox.  Use this tutorial on doing that.

Or this:…

Thanks Rob

It’s a full copy Sandbox for our development. We did the same refresh last week for our UAT. It worked fine. I am wondering why its not getting copied even though it full copy, Rest every thing got refreshed correctly.



After doing the changes and copying the pages from the Prod we are seeing alignment issue. as in screen shot

Ravi.  That refresh sure went bad!  It looks like more skuid resources didn’t get loaded.  I’m working with our dev team to understand what is happening here.  I’ll get back to you soon. 

This is evidence that more custom settings did not get moved. In this case the custom settings for themes. You need to add at least the Classic theme from your production org.

If this sandbox is really a full copy or developer pro sandbox we think you should contact Salesforce and ask why custom settings were not moved along with the refresh. What they have done (not moved data) makes us supect that they are treating your sandbox as a Non - Full - Copy. This will need to be corrected on thier end.

We recongized that there was a bug in our sandbox management code for Non - Full - Copy instances and will be fixing that in an upcoming patch. So if the sandbox is not really a Full Copy one, you shouldn’t see this problem again after we make that fix.

If you would like for us to review the org and ensure that all custom settings and components are in place, we’d be happy to do that. Just give us login rights and send us the Org ID by email.

Happy Friday…

Thanks Rob

Will share detail with you

but wondering why Only SKUID app has problem rest others are fine


For any ISV partners using TrialForce, you will get this same error if you upload a trial template as “setup only” and not “All Data and Setup”

Thanks for the head’s up…