Error log failing

When I update a record in sf my log files are created correctly.  When I use a managed package, Skuid, to update that same record the log files are limited and different.  I have the setting at finest or finer.  Why does it behave differently? This started about 10 days ago.

I think apex logging in managed packages vs non managed packages is more of a Salesforce issue than a Skuid issue. Do you know when the Salesforce Spring 16 update was pushed to your org? It may be a difference between Salesforce Winter 16 and Spring 16. As manage package vendors, we have no control of how Salesforce handles logging.

Yup.  You can grant Skuid access to the Org and they can log in via LMA and see if any additional information is available.  

Another thing I’ve noticed is that Apex logs can only be so big. So if you have a large apex log at something like “finer” or “finest”, you can see portions in the log where it says something like “* Skipped 7397754 bytes of detailed log”. I think the only workaround there would be to turn off or turn down certain log levels. If you’re really just looking for your own system.debug statements in your code, it’s probably best to put your apex logging on “debug” and turn everything else to “none”. That way you can be sure that your system.debug statement wasn’t part of the portion that was skipped.

Thanks Ben and Irvin,

I have never run into a size of log issue.  However, I believe Irving is right. I did seem to start happening when I went to the newest version of Skuid and SF did upgrade.  I just received this message from SF.

"Salesforce support needs to enable the debug logs for managed package, then only you would be able to see it.

Please provide us the following details.
1) Org Id where you want the debug logs to be enabled.
2) Namespace of the managed package."

I have given them info and I will let you know the results. Maybe the Spring 16 needs this done to all Skuid installs?

I am confused again? Here is salesforce response:

“I have checked your Org and can see that the owner of this Managed package(Skuid) is some one else. So, I would request if you could please get a confirmation email from them as it is their intellectual property rights along with the reason to get it enabled.

Also, on your concern, I would like to confirm that for a Managed package we need to get the debug logs enabled from Tier3 as its something related to a Third party and after getting installed a package we are required to enable debug logs for the same.”

I have granted Skuid access.