Error: Invalid Component tried calling function [get] with arguments [v.hostedComponent]

Hi -

One of my users is getting the following error on Salesforce1, accessing a Skuid Mobile page (screenshot attached).

User is:

  • using an iPad
  • on the latest iOS
  • works on his iPhone but not the iPad

Have you seen this error at all before/any guidance? Seems to be from my reading that it is maybe a Salesforce1 issue?

Thanks

Liz

Ugh.  I’ve not ever seen that error.  And the variables in play are somewhat mind-numbing.   But here are a few follow up questions. 

1. Are there other skuid pages that the user can access sucessfully? 
2. If the user gets the URL for the skuid page and tries to use the standard Safari browser to get to that page does it work? 
3.  Are the iphone and ipad on the same iOS level? 

Let us know and we’ll try to keep digging on the issue. 

We started with troubleshooting 101 - log out of Salesforce1, close down the app completely, restart iPad, sign back in. This seems to have fixed the problem. Maybe a permission/cookie conflict? 

At any rate we seem to have solved it for the time being. Thanks Rob!

Liz