Error Creating/Cloning Design System


I am currently using SKUID v2 12.2.21. I am having an issue in the design system page when creating a new design system. If I create using one of the standard DS (ink, lightning, skuid app) it lets me create it without a problem. If I try to create one using a custom DS I have created, I get an error on screen but no real context of what the problem is. The console logs are a bit more helpful, but not by much. They say “error - Not Found”. I believe this is implying that it can’t find the static resource with which to clone? Not sure. I thought maybe the underscore might be the issue, but I tested by trying to clone a custom DS without an underscore and still get the same error.


Also, I am curious if its possible to rename an existing custom DS system, and if that would have any impact to pages?

Hey @Nicholas_L , have you tried upgrading Skuid in sandbox and seeing if it resolves this issue? There were a lot of improvements to v2 between 12.2 and the current version 13.0.10.

I’m not sure about renaming a design system - you can always try it and then change it back if the pages don’t pick up on it.

How to Upgrade Skuid on Salesforce

  1. Instructions for upgrading
  2. Best practices for upgrading

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox to test all mission critical functionality before installing into a production environment. After upgrading, please also remember to update out of date Themes and Design Systems.

Hi Anna, thank you for reaching out. I’ve heard that a few times with some of the issues I have been having. I’d like to upgrade, the challenge is its a herculean effort of testing before I can do such an upgrade. I’ll look into it further.

Appreciate the feedback!