Error: Access to entity 'SalesforceContract' denied

I started getting this error in my sandboxes and production this week. The only thing I know of that is different is that we updated to the latest version.

Access to entity ‘SalesforceContract’ denied
The people getting the error are all SF admin with full Skuid licenses. No regular users have reported an issue. We get the error when previewing the page. I get a different error when viewing the page on a Salesforce Lightning page.
Error message: An internal server error has occurred
Error ID: 1132947858-480962 (1714735809)

Any ideas what is causing this?


Thanks for reaching out about this. We have noticed this in a couple of environments as well and are actively investigating solutions.

With our most recent release of Skuid we did add support for Salesforce API 57 and it appears with this API Salesforce has added support for an undocumented object called “SalesforceContract”. We think that this error most commonly occurs when using a polymorphic field that could potentially reference all objects in the Org, like LinkedEntityId.

We are actively investigating and will certainly circle back with any workarounds and/or findings on this as soon as we have them.

Hope you are well, and thanks again for reaching out!


1 Like

We definitely have linked entity id in several of our pages.
Any chance of going back to version 16.0.9?
That is actually the version I intended to install in production because that is what I had tested in my sandbox but we accidently installed 16.1.4.

Hi, TWyatt. As Clark mentioned, we are actively investigating this issue. It being undocumented makes it a bit tricky. It appears that this object doesn’t appear in all orgs, including our development and QA orgs, so we were not able to catch the issue before the release went out. We’re tracking it under the issue number CORE-4797, and we’ll add this post to the issue, so we remember to double back when it’s resolved. We’re really sorry for the inconvenience.

As far as rolling back versions of managed packages like Skuid goes, unfortunately Salesforce does not provide a way to do that easily. You have to completely uninstall the managed package which requires you to eliminate all dependencies on the package (e.g. remove the Skuid Permission Sets for all users, remove any Skuid page Lightning components from layouts, remove Skuid VF overrides…), then install the version you want and reimplement everything. In almost every case, it’s just not worth the hassle.

  • J.
1 Like

Dear TWyatt, quick update on this, we’ve seen the issue successfully resolved in another org by enabling Metadata Caching in the salesforce data source settings (on Skuid). Please find more information about it in our online docs here: Salesforce — Skuid v16.1.4 Documentation

Hope this helps!

I followed the article and enabled Metadata Caching but the problem still existed. I then refreshed the Metadata and it still did not resolve the issue.
Fortunately, this only affects the system administrator profile. Our regular users do not seem to be impacted by this issue. Does that make sense?

We are getting the same error. It is on a page that is referencing LinkedEntityId in the Files object. Once we removed the reference to this object, the error went away. I can send XML samples if needed.

Appreciate your help resolving this issue!

  • Meredith

This issue has been resolved as of July 21, 2023 in Edinburgh Update 1 versions 16.1.7+
Check out for the latest install links. Remember to install & test in sandbox first.

Thanks for your patience and please start a new thread if you encounter any further difficulties here.

1 Like

This topic was automatically closed after 10 days. New replies are no longer allowed.