element inside template Component disappears when using render() on any component

I am having a very frustrating problem.

I have added this multi-date picker calendar element to my Skuid page using a js inline snippet. It renders fine on page load, but I have another snippet that is running to update values in model and then I’m running render() function on the component using the model that was updated to display the change.

However, when I run the render() on a completely different component. My calendar element disappears!

What could be causing this?

I would post the skuid page XML, but it’s a HUGE Skuid page using lots of code.

I have the Multi-Date Picker Calendar element working by dropping a template component into my page and then using


I tried running render() on the template component too, but it doesn’t fix the problem.

Is there something in Skuid that would cause this to not render a custom div inside a template?

Nevermind, I fixed it!

By changing the id of the template to the id of the multi-date picker calendar div Id and removing the

inside the template…

Not sure why this works, but it works. If anyone can explain why I would appreciate it!