Edit page button has gone missing - how to get it back?

In the midst of removing and changing some permissions recently I seem to have lost the edit page button that is typically on the right middle part of the page.

Could someone please explain the components that control whether or not the “edit page” button is visible or not.


Do you have permission to edit skuid pages?

The permission sets you’d need are “Skuid Admin”, “Skuid Page Builder”, and “Skuid Page Viewer”

Hi Stephen, thanks for the reply. Yes I am our admin and I do have all 3 of those permission sets assigned to my user account.

Is it gone on all of your pages or specific pages individually?

All of them unfortunately

Does your user account have the ability to edit Skuid pages? Can they go in and change skuid pages in the Skuid composer?

Yes my user account does, I can edit pages if I go into the Skuid settings in the Skuid app and find the page I want to edit.

We recommend downloading a version of Skuid in a sandbox and comparing the sub-permissions in that environment with what you have now. That will be the best way to discover where the exact permission set is that needs to be switched.

Thank you.

I’m having the same issue. I enabled “Use enhanced domains” in Salesforce because I got a message today that this is going to be pushed in Salesforce Winter '23. With enhanced domains enabled, everything seems to work normally except that the edit button on the side of pages is now gone. Why? What can I do to use enhanced domains and still keep the edit button? Since Salesforce will be switching orgs to use enhanced domains in the future, how can we fix this to operate properly with enhanced domains? I disabled the use of enhanced domains for now, and immediately the edit button returned.