easy way to upgrade skuid for multiple orgs?

Is there a way that I can force multiple orgs to update that would be faster than logging into each org and using the release install url?

You can do a deploy using the Force.com Migration Tool (or nforce-metadata or something like that) on the InstalledPackage metadata type, specifying the version of Skuid that you’d like to upgrade to. You do have to do this to each org, though, so it might be about as fast to just login via the UI. 

Faster with grunt-ant-sfdc and multiple targets. :slight_smile: Thanks!

Zach, I’m getting this error when I attempt to deploy. What might be going wrong? The target org has skuid installed, but not the version indicated in the deployment (which is whole reason for attempting this deployment)

This is what the file looks like that I’m trying to deploy:

Just to be sure — this is the only metadata you’re trying to deploy, correct? And you are deploying along with a package.xml that looks something like what is described here?

https://developer.salesforce.com/docs/atlas.en-us.packagingGuide.meta/packagingGuide/packaging_api_i…

Also, what version of the Force.com Migration Tool are you using? 

Yes and yes.
Spring '16

But I’m not using the Force.com Migration Tool directly, I’m using the latest version of grunt-ant-sfdc (1.2).


Not sure what’s up. I’d try it with the raw Migration Tool and see if you can get that to work. If you can, then there must be an issue with grunt-ant-sfdc

the migration tool itself also fails:

c:worksalesforce_antOptimizeDev&gt;ant deployBuildfile: c:worksalesforce_antOptimizeDevuild.xml<br>deploy:<br>[sf:deploy] Request for a deploy submitted successfully.<br>[sf:deploy] Request ID for the current deploy task: 0Af3600000dc8c7CAA<br>[sf:deploy] Waiting for server to finish processing the request...<br>[sf:deploy] Request Status: Pending<br>[sf:deploy] Request Status: Failed<br>BUILD FAILED<br>c:worksalesforce_antOptimizeDevuild.xml:40:<br>*********** DEPLOYMENT FAILED ***********<br>Request ID: 0Af3600000dc8c7CAA<br><b>All Component Failures:</b><br><b>1. &nbsp;installedPackages/skuid.installedPackage -- Error: Package Not Found</b><br>*********** DEPLOYMENT FAILED ***********<br><br>Total time: 12 seconds

Have you tried any other package versions? 

I haven’t. I’ll give 8.6 a try.

8.6 works. 8.7 fails.

Confirmed. I added support for installedPackages to grunt-ant-sfdc. I am now able to update to 8.6 with the raw migration tool and with grunt. But every attempt to update to 8.7 ends in Error: Package Not Found.

I’m not sure why 8.7 cannot be found by the tool. Very strange.

Can you try again?

Just tried. Failed. Unless I need to somehow refresh something?

Okay, good to know, we tried something on our end regarding to the package version in question and it obviously didn’t help :frowning:

Looks like we can upgrade to 8.8 this way without any problems.

I’m getting the Package Not Found error again when attempting to deploy 8.11.

Maybe it has something to do with odd numbered versions?