Double click to edit is disabled on native salesforce view page after deploying visualforce "edit" a

We have an object with multiple record types. We are only overriding 1 of the record types with a Skuid page. We use the skuid page assignments to accomplish this. However, after we added the visual force page to override the “Edit” action, the record types that have native salesforce layouts aren’t allowing a double click to edit fields. Users are required to click the “Edit” button the page to put it into edit mode.

Is that the expected/known behavior?

Visualforce page for “Edit” action override:

<apex:page standardController=“Request__c” extensions=“skuid.Redirects” action="{!redirect}&objecttype=Request__c&actiontype=Edit">


Salesforce Enterprise w/ Classic UI
Skuid 12.0.2

And yes, the plan is to move ALL the record types to Skuid pages which would resolve the issue, but we are having to convert record types to skuid pages over time causing the mix of interfaces.

I ran into this issue as well. Unfortunately, the inline-edit feature is disabled by Salesforce when a page override is used, even if you aren’t using an override for every record type, profile, etc.

Here’s the Salesforce Idea that is hoping to fix this 

However, I did find this work around. You can create a new VF page for View that enabled inline-editing. I haven’t tried this, but it might work!

@ Sam Becker - thanks for sharing this. I appreciate it. I tried adding the inline edit attribute to the visual force page that overrides the View action on the object, but its still not allowing double click edits.

I tried this:

<apex:page standardController=“ObjectAPIName” extensions=“skuid.Redirects” action="{!redirect}&objecttype=ObjectAPIname&actiontype=View"><apex:detail inlineEdit=“true”/></apex:page> ```I UpVoted the salesforce idea.

Thanks again for sharing.