Design System Won't Save after update but works fine in Sandbox

Upgraded Skuid to 14.4.11 into Sandbox. Everything worked great. Updated Production this morning. Design Systems is not working. New design system can be created but if the saved it says “There was a problem saving this design system”. The save button goes away and I can continue editing but no saves actually occur. For instance I am changing branded colors. Hit save get error message. Leave design system and come back in and no changes were made and it is back to the default.

I I click into the Skuid Admin Design System it just continue to load. But behind the gray there is an error at the top of the screen that says "There were 1 problems with this Skuid Page. 1 There was a problem initializing a component of type skuid_page. Cannot read properties of undefined (reading ‘Name’). I wonder if that gives a hint to the other error.

Again, no issues in Sandbox only in production.

A description of the bug

V2 Design System
SKUID 14.4.11

Design System is not working. I can create a new design system in V2 but then additional saves are not made. I tried clicking Update All and it says it updated. But then if I try to leave the page it says changes will not be saved. Updated date still shows 2 years ago.

When trying to save changes to the design system it “There was a problem saving this design system”

Saving the design system.

It should have saved.

It doesn’t save.

Hi Rich,

  • Is your Sandbox also on 14.4.11?
  • What’s the name of the design system?
  • What property(s) are you trying to update?

I was able to create a new design system in 14.4.11 this morning and make additional saves.

Hi Anna, thank you for your help.

Yes, the Sandbox was refreshed and then updated on Sunday. It is on 14.4.11 as well. In the Sandbox the design system is called Fusion.

In Production I created one called Fusion as well but when it wouldn’t save I deleted it and created one called Test. No special characters etc in any of the names.

The design system I was creating is a V2. Though I did go into production and try to edit an old V1 and it would not save either.

I clicked “Update All” in production and it pretends to do it but I have a hunch that it is not saving either because if I try to leave the screen it warns me there are unsaved changes. Typically “Update All” is conditionally rendered and does not show once it updates. In production I can still see “Update All” even after updating and refreshing the page.

I was updating brand colors and components but it doesn’t matter what I try to save. For instance I can go in fresh and just change the Typography Body text from 13 to 14 and hit save and get the same “There was a problem saving this design system: Test”. (Test is the name of this particular design system in production).

Thanks! The team is following up with you directly. When the issue is resolved, we will post the resolution here.

The solution to this problem was going into My Domain and turning on the Edge Network and Enhanced Domains. Thanks Skuid team for presenting me with the solution.

This briefly was the solution. But after a couple days it no longer solves the problem, or a new Salesforce generated problem has been introduced. No settings were changed internally on my side from it working to it not again. Ticket has been updated with Skuid Support Team.