Date Input displays "Invalid Date" after saving form

I’ve got a V2 Spark (12.1.3) page where the user inputs a date in an Edit form and then clicks a “Done” action, which saves the record and changes the form to Read with in-line edit using the Change Read/Edit form action. Then date that was just input shows as an Invalid Date to the user. This clears up if the user refreshes the page.

It only appears to do it when the date goes from Null to a value - so it’s like the UI isn’t refreshing with the saved value. Any fix for this?

This is happening in Lightning run time. I tried to repro it on page preview (so VF deployed) and it will throw the invalid date if I null out the date. So maybe a similar problem.


This is happening to me.  Any fixes.

It happens with read only and inline edit

This is a hacky solution suggestion…but could you try toggling that specific field to be hidden at the beginning of the save action sequence then toggling it back to be shown at the end of the action sequence. Just an idea since the issue sounds like a rendering problem that goes away upon page refresh.

Thanks. However, page refresh does not fix problem

I’m showing “Invalid date” on every/any date field that isn’t populated when in read only or read with inline edit mode. It’d be nice if these went back to populating blank like in V1.

Any update on the bug fix release timing?

Chandra, I just tried replicating and I’m seeing some strange behavior as well - instead of saying “invalid date”, it’s just blank after saving; however, if I click the pencil to edit the field, the value is retained. I’ll check and see if this has been reported and whether a fix is coming soon. Thanks!

Any update on when this will be fixed?

The fix for this issue is slated for the next maintenance release, Spark 12.1.9, which is scheduled to be posted to Skuid releases later this afternoon (Tuesday August 20, 2019).

The fix for this issue has been released in Spark 12.1.9, which is available from the Skuid releases page.