Data Entry Wizard conditional link to records

I have made a data entry wizard to manually enter the data in account, contact and opportunity records, it seems to work all fine when the account has two contacts linked to it, because i have limited the max. number of records to be loaded to 2, which is ideally needed because each one of my account belongs to a couple, but if an  account has only one contact linked to it, the ondition to load just 2 records work against it and it uploads 2 records again one whichis linked to the account and the other from anywhere in salesforce.

The model Contact has the condition to fetch records where account id is the value of id field returned by first row of account model, account record is determined by the id parameter of URL. 

I tried using rendering conditions on the fieldeditor but that dint worked at all
it doubled up the model when the condition was true.

Please help me solve this problem

I have also tries using two different models for contact object and using the field condition on one of them that says “Primary_contact__c= true” i.e fetch the contact record where, field named primary contact = true the other does not have any such condition it just fetches the contact record linked to account and i limited both the models to fetch only one record, but this dint worked at all.

Please help solve this…!!


Is there only one couple linked to each account, or can an account have multiple couples or a couple have multiple accounts? If there’s only one couple to each account then you shouldn’t have to limit the number of records to two. Instead, the model condition on contact that looks to the id of account should limit the contact rows. I’m sure it is, but is the account id condition working properly and only pulling one account record in? Check against this:

and make sure the parameter is Id and not id. Additionally, what model is the field editor on?


I am using something like this as the Page URL{{WhatId}…

And the contact model has the following condition on it

Account model has this one

but case is the same…!!
As advised by you that max. number of records to load should not help sort this. if i donot limit it to a certain number it brings up infinite number of records…!!

Can you please help me with this


It looks like the issue might still have to do with passing the account record id to the page. In the row action on the account table, the url must end with {{name of id field}}, and it is case sensitive. That means that id won’t work, but Id should work. So the end of your url would look like DataEntry&id={{Id}}

On the corresponding page that it redirects to you can see that I set a condition on account to look to whatever I named the parameter I passed in. In this case, id.

It might be helpful to check this first to make sure that you’re only getting one account record. Then once you only get one account the condition on contact should hold and you should not get all the contact records (your condition on contact looked good so I don’t think you should have to change it). One last thing to do that might help is checking that you have the Id field in all of your models, like how you can see my Id field on my account model in the top screenshot.



yes you were right … even after carefully looking for the ID parameter in the redirect URL i did the same mistake … just was being careless…
Thanks for your help though

I was trying to test the wizard… since it is a data entry wizard i just wanted to make sure that all the data entered is correctly being pushed to SF in all the right places or fields… but when i tested it i am getting all the data stored against the standard objects but anything stored against the custom objects is not coming through… Can you please help me with this i am attaching the screen shots along with… it shows the actions behind a Save button on the wizard…

                                                                            Actions start from here  

They are in this sequence:
Show message and vBock UI
Save changes in Account
Save changes is contact
Save changes in Assets and Liabilities
Save changes in Property portfolio
Save changes in Expenses
Redirect To URL
Unblock the UI

out of all these accounts, Contact,Assets and liabilities are standard objects

others are custom objects
Also i have added “Save changes to model” action on the “next step” button in the previous step
Can you please help me with this also??


Is there a specific reason to put the models in their own actions? It’s typically best practice to save all your models in one action (the error checking will still work). It shouldn’t affect if they get saved or not, but I’d encourage you to try it just in case. You might also try unblocking the UI and then redirecting. Typically you unblock the UI and then take your next steps, such as redirecting or going to the next step. 


i tried your way but nothing fixed the issue
Custome objects dont have any records created against them, but standard objects do have all of them

What should i do?

Sorted…!! All Solved
they were all created but not linked to the account object… fixed it
Thanks a lot for your help Amy

This reply was created from a merged topic originally titled Data entry Wizard. I have built a page of the data entry on SF records against Accounts, Contacts, Opportunity and some custom objects.As soon as the any Lead is marked as in office booked it is converted and we need to do the data entry on accounts, contact and opportunity, every account will have only two contacts associsated with it which is a couple, when I start data entry wizard the it only brings up one of the contact records assosciated with the account, not both of them as is visible below… This field editor is rendered on the marital status field on account which is on first page of the wizard, I wish to change it to fetching both the contact records

Please help me with this…Also Can i render one of the Steps in the wizard


I’m glad to hear you got it working, and you’re welcome!