custom theme css not loading in force.com site


I believe the URL needs to be https://compasscare.secure.force.com/support/resource/…

/support is the force.com site.

Acknowledged, this is a bug, it will be fixed in Banzai Update 5 (7.22+).

I am still getting this issue as of 7.27.1 in Production only, works fine in Sandbox. Installing yesterday’s release (7.31) hoping that will fix.

Specifically, the font SalesForce Sans will not load in Production, but it does in Sandbox.

See https://full-kalawpc.cs19.force.com/pec/
vs. https://www.fullskope.com/apex/ests_PECAppIntake

Nope, didn’t fix it. What’s weird is that I get the same error in the console in both Sandbox and Production, but Prod just won’t load any web fonts, Google or Static Resources. 

Made some progress - for some reason even though my Global Font Family is set to SalesForce Sans, the highlighted part here, link to stylesheet, is linking to opensans in the Skuid Fonts static resource. In Sandbox this links to /resource/skuid__Fonts/sfsans/sfsans.css like it should. When I replace this then everything looks like it should

This is in the HEAD of my html, how the heck do I edit that??

Jack~

Per your communication, it sounds like you have resolved this. Is that true or do you still need assistance with this? 

Thanks!
Karen

Hi Karen,

No it’s not resolved unfortunately, I still can’t get SalesForce Sans to load in Production. That’s been an ongoing issue and I was using Open Sans as a fall back font, but then when that stopped working I really freaked out and sent that support email. So Open Sans is working again, so less urgent, but still not sure why SalesForce Sans or ANY Google Web Fonts won’t load for force.com site skuid pages in Production. Thanks!

Have you tried clicking “Update Out-of-date Themes” from the Themes list?

Yes, after doing that is when Open Sans stopped working as well, not sure how that started working again. Google Web Fonts or fonts from the skuid__Fonts resource have just never worked in Production. I wonder if it’s because we are using a custom domain, fullskope.com, and a security certificate? Maybe it won’t load resources? But you can access https://www.fullskope.com/resource/skuid__Fonts/sfsans/sfsans.css so I’m not sure why it wouldn’t load in runtime. 


Was there ever a resolution to this?

I believe this is an issue now with skuid v2 pages not loading the theme properly when using a custom domain: https://community.skuid.com/t/custom-domain-using-a-public-facing-page-getting-error-about-theme-components-in-v2?topic-reply-list%5Bsettings%5D%5Bfilter_by%5D=all&topic-reply-list%5Bsettings%5D%5Bpage%5D=1#reply_20467614