Conditionally Rendered Wizard Buttons Not Being Fully Removed when conditionally rendered out

When buttons in a wizard have conditionally rendering applied, after the button has shown at least one time, it is never fully removed when its condition evaluates to false.

There is a small piece of the button image still visible, it’s clickable and the button responds to hotkeys when it has been conditionally rendered out.

Steps to reproduce:

  1. Create page using XML below
  2. preview page picking an account

Expected = Actual
“Not Option 1 (Ctrl+Shift+M)” shows, “Option 1 (Ctrl+Shift+L)” does not show and there is no button fragment showing nor does it respond to hotkeys

  1. Change Mode to “Option 1”
  2. Press Ctrl+Shift+M

Expected
“Not Option 1” is completely hidden/removed and does not respond to hotkey

Actual
There is a button fragment visible, the fragment is clickable and hotkey is fired

  1. Change Mode to “None”
  2. Press Ctrl+Shift+L

Expected
“Option 1” is completely hidden/removed and does not respond to hotkey

Actual
There is a button fragment visible, the fragment is clickable and hotkey is fired

Sample Page XML

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true" tabtooverride="Account">   <models>
  <model id="Account" limit="1" query="true" createrowifnonefound="false" sobject="Account" adapter="" type="">
     <fields>
        <field id="Name"></field>
        <field id="CreatedDate"></field>
        <field id="Mode" uionly="true" displaytype="PICKLIST" label="Mode">
           <picklistentries>
              <entry value="one" label="Option 1"></entry>
              <entry value="two" label="Option 2"></entry>
           </picklistentries>
        </field>
     </fields>
     <conditions>
        <condition type="param" enclosevalueinquotes="true" operator="=" field="Id" value="id"></condition>
     </conditions>
     <actions></actions>
  </model>

Skuid Team - Any input on this?

Hi Barry

I once faced the same issue as you do and after trying for about 8 hours to find a proper workaround for the problem, I gave it up.
I figured out a hacky workaround never the less: I hid the buttons completely using CSS (assign/remove the class conditionally using a snippet in model actions).
The only difference was that there were no hotkeys for the user, which made my solution passable. I don’t think that this will work for you, but you could give it a try. Give me a shout if you need some sample snippets :slight_smile:

Looks like it’s a skuid bug never the less :frowning:

Cheers

Thanks David, appreciate the insight and offer to help!  Yes, I’ve managed a very hacky workaround with limited success but as you mention, definitely a skuid bug that should be addressed.

Always glad to help :slight_smile:

Do you know if it got acknowledged by the team?

As far as I know, this has not been officially acknowledged yet.

Skuid Team?

Just tested this with Skuid 8.8 and it appears to have been resolved in a recent build.

Skuid Team - Can you confirm that this has been resolved and if so, in which build it was fixed?

I believe this got fixed in conjunction with SKUID-1897. Mentioned in the newly added technical release notes on skuid.com/releases.

Thanks Ben!